Installing/enabling Collabora Online

Hi everyone,

After I discovered Nextcloud yesterday, I was happy as a child to install it. Everything seems to be working fine after installation except Collabora Online.

I keep getting the error “Could not establish connection to the Collabora Online server.” without any explanation why, and the system logs keeps spamming “Error PHP Module ‘sqlite3’ already loaded at Unknown#0”.

I don’t if that is the cause and if so, how do I fix it? I tried the option ‘Use your own server’ and didn’t work either…

And I can’t find my fix on Google either…

Nextcloud is running on;
Linux 3.10.0-962.3.2.lve1.5.24.7.el7.x86_64 x86_64
with CPanel
PHP 7.4

Version: 7.4.9
Memory Limit: 4 GB
Max Execution Time: 3600
Upload max size: 1 GB

Type: sqlite3
Version: 3.26.0
Size: 1,7 MB

Do you have a Document Server installed from the APPS?
Have you tried a DEMO server connection ?

for your sqlite3 error check /etc/php/7.n/apache2/conf.d/nn-sqlite3.ini
where n are numbers

and change
extension=sqlite3.so
to
; extension=sqlite3.so

I will look into that sqlite3 error. I ended up using ONLYOFFICE, because I’m spending too much time on fixing the errors of Collabora.

The demo server connection of Collabora works fine, it doesn’t allow me to select the first option and second one. When I use the first option ‘Use your own server’ it hops back to the second one ‘BUILT-IN’.

And all it says is ‘Could not establish connection to the Collabora Online server.’.
I think Collabora needs to work on specifying errors so I users know where to look…

ONLYOFFICE looks fine and I think I will keep this one instead.