Installed version does not support upgrading - 18.0.3 to 18.0.4

I currently have version 18.0.3. Need to catch up a bit!

Even selecting a minor step, 18.0.3 to 18.0.4, gives the warning that “The selected version, or a version between it and the installed version, does not support upgrading”

Any guidance available?

Been trying to find upfrade tool but can’t find anything.

Thanks

EDIT - this is a hosted system so I only have cpanel access tool.
EDIT 2 - have tried the /upload/ system on the nextclouf installation on server. Gives an error “The following extra files have been found: .hteamq8g50n37i.data”.
This is the folder with all the content for the various users.