Installation Failure message on HOSTEUROPE webspace

Hello,

I tried to install nextcloud on my webspace at Hosteurope. Everything went find up to the moment were I like to finish the installation.
Nextcloud asked for the username the passwort and the selection for the database.
I selected the MySQL option and add all neccessary information.
When I press the “Installation” Button I receive the following error message:

Interner Serverfehler
Der Server hat einen internen Fehler und konnte Ihre Anfrage nicht vervollständigen.
Bitte wende Dich an den Serveradministrator, sollte dieser Fehler 
    mehrfach auftreten, und füge Deiner Anfrage die unten stehenden 
    technischen Details bei.
Weitere Details können im Serverprotokoll gefunden werden.

Technische Details
Entfernte Adresse: 91.13.222.156Anforderungskennung: ZjBZEvXNPHklRnyJ/8Kc

In the error log I get
[Mon Aug 01 21:13:02 2016] [error] [client 80.237.133.69] client denied by server configuration: /is/htdocs/xxxxxxxxxx_yyyyyyyyyy/cloud/data/htaccesstest.txt

I’m lost and also the support from hosteurope couldn’t help me.

Does anybody made the same experience and find a solution?

Thank you in advance.
uli2502

This error is not related to your problem. Can you check the other logfiles (if possible, at least owncloud.log): https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808?u=tflidd

The database server is on the same host? Or is it a different machine? Do you have SSH-access?

Hi uli2502,

I am having a similar problem also. Did you solver yours already?

The logfiles would be more helpful to solve this problem.

I wrote the content of my log file and the actual problem here:

Are you familiar with this kind of error tflidd?

Hi tflidd,

in the owncloud.log I find the following entries:

{“reqId”:“ZjBZEvXNPHklRnyJ/8Kc”,“remoteAddr”:“91.13.222.156”,“app”:“mysql.setup”,“message”:“Database creation failed: An exception occurred while executing ‘GRANT ALL PRIVILEGES ON xxxxxxxxxx-nc . * TO ‘xxxxxxxxxx-nc’’:\n\nSQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user ‘xxxxxxxxxx-nc’@‘localhost’ to database ‘xxxxxxxxxx-nc’”,“level”:3,“time”:“2016-08-01T18:58:01+00:00”,“method”:“POST”,“url”:"/cloud/index.php",“user”:"–"}
{“reqId”:“ZjBZEvXNPHklRnyJ/8Kc”,“remoteAddr”:“91.13.222.156”,“app”:“index”,“message”:“Exception: {“Exception”:“Doctrine\\DBAL\\Exception\\DriverException”,“Message”:“An exception occurred while executing ‘CREATE TABLE oc_addressbooks (id BIGINT UNSIGNED AUTO_INCREMENT NOT NULL, principaluri VARCHAR(255) DEFAULT NULL, displayname VARCHAR(255) DEFAULT NULL, uri VARCHAR(255) DEFAULT NULL, description VARCHAR(255) DEFAULT NULL, synctoken INT UNSIGNED DEFAULT 1 NOT NULL, UNIQUE INDEX addressbook_index (principaluri, uri), PRIMARY KEY(id)) DEFAULT CHARACTER SET utf8 COLLATE utf8_bin ENGINE = InnoDB’:\n\nSQLSTATE[42000]: Syntax error or access violation: 1071 Specified key was too long; max key length is 1000 bytes”,“Code”:0,“Trace”:”#0 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/3rdparty\/doctrine\/dbal\/lib\/Doctrine\/DBAL\/DBALException.php(116): Doctrine\\DBAL\\Driver\\AbstractMySQLDriver->convertException(‘An exception oc…’, Object(Doctrine\\DBAL\\Driver\\PDOException))\n#1 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/3rdparty\/doctrine\/dbal\/lib\/Doctrine\/DBAL\/Connection.php(945): Doctrine\\DBAL\\DBALException::driverExceptionDuringQuery(Object(Doctrine\\DBAL\\Driver\\PDOMySql\\Driver), Object(Doctrine\\DBAL\\Driver\\PDOException), ‘CREATE TABLE o...')\\n#2 \\\/is\\\/htdocs\\\/xxxxxxxxxx_yyyyyyyyyy\\\/cloud\\\/lib\\\/private\\\/db\\\/mdb2schemamanager.php(167): Doctrine\\\\DBAL\\\\Connection->query('CREATE TABLEo…’)\n#3 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/lib\/private\/db\/mdb2schemamanager.php(70): OC\\DB\\MDB2SchemaManager->executeSchemaChange(Object(Doctrine\\DBAL\\Schema\\Schema))\n#4 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/lib\/private\/db.php(172): OC\\DB\\MDB2SchemaManager->createDbFromStructure(’\/is\/htdocs\/wp10…’)\n#5 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/lib\/private\/installer.php(586): OC_DB::createDbFromStructure(’\/is\/htdocs\/wp10…’)\n#6 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/lib\/private\/installer.php(562): OC_Installer::installShippedApp(‘dav’)\n#7 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/lib\/private\/setup.php(370): OC_Installer::installShippedApps()\n#8 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/core\/controller\/setupcontroller.php(64): OC\\Setup->install(Array)\n#9 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/lib\/base.php(917): OC\\Core\\Controller\\SetupController->run(Array)\n#10 \/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/index.php(39): OC::handleRequest()\n#11 {main}",“File”:"\/is\/htdocs\/xxxxxxxxxx_yyyyyyyyyy\/cloud\/3rdparty\/doctrine\/dbal\/lib\/Doctrine\/DBAL\/Driver\/AbstractMySQLDriver.php",“Line”:115}",“level”:3,“time”:“2016-08-01T18:58:02+00:00”,“method”:“POST”,“url”:"/cloud/index.php",“user”:"–"}

Best regards
uli2502

Related to your error, I found this: https://github.com/owncloud/core/issues/23988
Does your mysql support the InnoDB engine?

@dbaray: These errors are expected, if you already give the credentials for the future NC-user (the script always tries, if it is an admin account and then creates a restricted user, so these errors are somehow expected). Do you have config/config.php? If yes, what happens, if you again open the URL of your cloud? Are there any new entries to the logfile?

Thank you for following this up @tflidd …very much appreciated

I have the following config.php

<?php $CONFIG = array ( 'instanceid' => 'oc9a77hhkqb5', ); When I try to open the URL of my cloud, it again shows the setup page. If I write the same admin user name, it tells me that user already exists and adds the following line to the log: "app":"mysql.setup","message":"Database creation failed: An exception occurred while executing 'GRANT ALL PRIVILEGES ON `or_nxcloud` . * TO 'or_nxuser'':\n\nSQLSTATE[42000]: Syntax error or access violation: 1044 Access denied for user 'or_nxuser'@'localhost' to database 'or_nxcloud'","level":3,"time":"2016-08-04T20:43:49+00:00","method":"POST","url":"\/nextcloud\/index.php","user":"--"} After this, when I try a new admin name, I see the HTTP 500 error. And a new line is added in the log which writes the same error above.

I noticed that the config.php changed to the following after HTPP 500 error:

<?php $CONFIG = array ( 'instanceid' => 'ocah3b0kr1th', 'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxx', 'secret' => 'xxxxxxxxxxxxxxxx', 'trusted_domains' => array ( 0 => 'xxxxxxxxx', ), 'datadirectory' => 'xxxxxxxxxxx', 'overwrite.cli.url' => 'xxxxxxxxxxxxxxx', 'dbtype' => 'mysql', 'version' => '9.0.53.0', 'dbname' => 'or_nxcloud', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'or_nxuser', 'dbpassword' => 'xxxxxxxxxxxxxx', );

I noticed this in error.log which I had not ealier:

[04-Aug-2016 21:02:43 UTC] PHP Fatal error: Out of memory (allocated 15204352) (tried to allocate 1138 bytes) in …/public_html/nextcloud/lib/private/log.php on line 287

It seems like this might be the main problem.

I increased the PHP memory to 128M in my PHP.ini. I can see in my phpinfo page the following line:

memory_limit 128M

But I still have the HTTP 500 error when I do a clean install with the same error.log saying Out of memory.

I need to double check, but it seems that my provider does not has InnoDB in this package.

I found the config.php with following entry:

<?php $CONFIG = array ( 'instanceid' => 'oc78g5awvgof', 'passwordsalt' => '43exESuZwBuyWZvZ7GX9e2o5qKNmkr', 'secret' => 'CYD0uM7oK7tMxZuzjzptaYS1p6tRwwoJhtHY/M6vhMbIwEYn', 'trusted_domains' => array ( 0 => 'wpxxxxxxxx.server-he.de', ), 'datadirectory' => '/is/htdocs/wpxxxxxxxx_9SM9JMWPEL/cloud/data', 'overwrite.cli.url' => 'http://wpxxxxxxxx.server-he.de/cloud', 'dbtype' => 'mysql', 'version' => '9.0.53.0', 'dbname' => 'dbxxxxxxxx-nc', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'dbuser' => 'dbxxxxxxxx-nc', 'dbpassword' => 'NU2o8azog4', ); When I re-open the URL the installation routine starts again. Then I need to create a new user. The installation finished with the same failure result.

My php version was 5.6, I changed to php 7 and increased the memory_limit in php.ini. This solved the problem. I hope you can also solve your @uli2502

Not sure what went wrong. There are only two entries missing:

'installed' => true,
'maintenance' => false,

I’m not sure what the installer does during the last steps and why it failed. If it got so far and was able to install tables, the permissions on the database are ok.

Do you have webserver-logfiles? A timeout could be the reason, if that is not the case, you should ask a developer if you can just add the missing lines…

I have the same problem, is there a workaround?

Did you try to switch to PHP 7 and to increase the memory limit ( Installation Failure message on HOSTEUROPE webspace)?

Hi tflidd,

thanks for your reply. Unfortunately I am rather restricted because I am using a using a shared web hosting service. My provider does not (yet) support PHP 7. He has announced it for the end of the month. I guess I will just have to wait…

All the Best