Installation - Configuration was not read or initialized correctly

Installed Nextcloud and MariaDB Database via command line (straight install not using docker or anything else) on Fedora desktop 38. Created DB user and tried to going to the website and I receive the following error:

Configuration was not read or initialized correctly, not overwriting /var/www/html/nextcloud/config/config.php

just to verify I changed the folder permissions → chmod -R 770

I am still receiving the same error. When I google the error I see a lot of fixes when dealing with Docker images but nothing for how I am running everything. Any suggestions would be appreciated. If more information is needed let me know.

On Fedora, the default HTTPD User is typically “apache”. Am I right?
Did you

sudo chown -R apache:apache /var/www/html/nextcloud

as well?

Hope that helps,
much luck!

Tried this and now instead of the Nextcloud webpage with the above error I listed I now am getting a white page with the following error:

App directory “/var/www/nextcloud/apps” not found! Please put the Nextcloud apps folder in the Nextcloud folder. You can also configure the location in the config.php file.

The installer information that I followed had me install everything under “/var/www/html/nextcloud/” which I would assume why I am getting the error. Should I just move the nexrcloud folder up one directory?

But we have at least solved one obvious error.

You should provide a link. Apps should always be installed in the apps folder.

NextCloud manual install

I used the netcloud manual install paged and pieced everything together. Essentially verified my php install, installed the MariaDB database using dnf, created the user, wget to retrieve the latest version of nextcloud, tar the file and moved it to /var/www/html./nextcloud.

configured Apache for nextcloud by editing /ect/httpd/conf.d/nextcloud.conf with the virtual host info and restarted httpd.

Got my original error and now the error with the white page after using chown to change ownership to apache as suggested.

How did you do that?
Did you leave the files structure unchanged after unpacking?
What Archive did you download? Frome here: Nextcloud server changelog ?
Is there a folder:
/var/www/html/nextcloud/apps ?
If not, RE-Read the manual (and not only one section) and start from scratch.

Much luck!

Yes downloaded from the link you indicated.

tar -xjf nextcloud-27.0.1.tar.bz2

/var/www/html/nextcloud/apps yes the folder is there

I would try things again:

# move first atempt
sudo mv /var/www/html/nextcloud /var/www/html/nextcloud-old
# check integrity of downloaded file 
[ "$(md5sum nextcloud-27.0.1.tar.bz2 | awk '{print $1}')" = "$(curl -s | awk '{print $1}')" ] && echo "MD5 match" || echo "MD5 mismatch"
# extract directly on the right location
sudo tar -xjf nextcloud-27.0.1.tar.bz2 -C /var/www/html/
sudo chown -R apache:apache /var/www/html/nextcloud

Since you already did the setup steps for your webserver and php and the database got created, you could now run → the installation-wizard ←

Much luck!

when trying the installtion wizard I get the same error as i was originallt getting. So I removed httpd, php, and mariaDB. I then reinstalled each one and created a test php page. I go to locahost and the test page appears as expected.

I download and install nextcloud, set permissions and now Im getting the requested url is not found when trying to access localhost/nextcloud

Screenshot from 2023-07-27 10-33-26


Getting the same error with a simple Portainer Stack install…

Any ideas?