Installation Collabora Online on Plesk

I would like to install Collabora on a server managed by Plesk onyx.
Server’s enviroment:
CentOS 7.3, PHP7.1, Nextcloud12
I have not used nginx yet. The server is operated only by Apache.

I tried installing “Collabora/code” from “Docker” menu in Plesk, but I don’t know the setting items at all.

“Volume mapping” and “Environment variables”.
How do I set these up?

Can I proceed with the normal installation process after completing the setting of that Docker container?
https://nextcloud.com/collaboraonline/

Is there a different installation method via Plesk?

I continued to build until I managed to display Collabora Online. However, I can open the application like an attached file, but the contents are not displayed. This is the same for new spereadsheet creation.

“Initializing…” is displayed momentarily at the beginning.

What can I set up in the future, will Collabora online function properly?

I am currently looking into the setting below.

location ~ ^/lool/(.*)/ws$
location ~ ^/lool {
location ^~ /lool/adminws {

I think that it is a matter of specifying the location of “lool”.
How do I find and specify the location of “lool (and loleaflet or hosting)”?

The reason that Collabora doesn’t start properly was that the environment variables were uppercase and that the server was not restarted. In case of Plesk, when changing settings with UI, I have to modify environment variables to uppercase. Environment variables must be lowercase. In Plesk, I need to install Collabora with SSH only. In Plesk, I need to install Collabora with SSH only.
I restarted Docker, nginx, php - fpm etc, but it seems it was useless. By restarting the server I can now use Collabora.

How many Collabora users are there?
Please tell us for future reference. About setting of nginx additional directive.

About “lool”. Reference values were different depending on the site.

official:

location ~ ^/lool {
	proxy_pass https://localhost:9980;
	proxy_set_header Host $http_host;
}
location ~ ^/lool/(.*)/ws$ {
	proxy_pass https://localhost:9980;
	proxy_set_header Upgrade $http_upgrade;
	proxy_set_header Connection "Upgrade";
	proxy_set_header Host $http_host;
	proxy_read_timeout 36000s;
}
location ^~ /lool/adminws {
	proxy_pass https://localhost:9980;
	proxy_set_header Upgrade $http_upgrade;
	proxy_set_header Connection "Upgrade";
	proxy_set_header Host $http_host;
	proxy_read_timeout 36000s;
}

other site:

location ^~ /lool {
	proxy_pass https://localhost:9980;
	proxy_set_header Upgrade $http_upgrade;
	proxy_set_header Connection "upgrade";
	proxy_set_header Host $http_host;
}

There were two patterns as described above. In my case the latter(other site) was able to connect.
The latter is intended for all “lool” directories and below. Is this recognition correct? In other words, I do not need to write “(.*)/ws$” or “/lool/adminws”.

I don’t seem to be able to connect if it is an official method.
If it is the official method, lool directory will not inherit ‘Upgrade’. “Upgrade” is inherited only for ws file(directory) or adminws file(directory). Besides ws and adminws, is there a directory where “Upgrade” should be inherited?