Install collabora and

Anybody who wants to help me to install collabora and

Every body.

I have running server here on raspbian+apache2 with autorun systemd module. Could help you with that, if your platform is moreless similar.


I have installed in ubuntu 16.04 lite/ apache2 too. I think it is very similar I do not know. If you could help me with this I will very appreciate. Another thing… I have SSL certificate run in
Thank you.

Okay, I will provide some step-by-step guide the later evening on how I did.

I saw your request in the other thread and as you also asked for collabora, it is as far as I know often done with docker. It is also possible to install with docker and there might be some synergy I don’t know about. However I installed spreed without docker, just keep that in mind, when you get some reply on the other thread.

thank you,
I do not know about collabora because another guy told me that the app has a limitations about how many users can be open the app at the same time… I do not understand why has limitations. But if you know about this please tell me… and if you can help me with this too I will appreciate.

I never used or installed collabora, so no idea about this ;). but here the step by step guide on how I installed on my system. I guess you also want to do video calls through out your local network, so I add the steps to install coturn as TURN server, which provides successful video calls through all kind of NAS etc. It is moreless a merge of these two guides:
Complete NC installation on Debian with and TURN step by step
[Spreed.ME] Howto autorun "spreed-webrtc-server" step-by-step

  1. Go to nextcloud web interface, app store and enable Spreed.ME client app, which is however found in category tools.

  2. Go to admin panel, additional settings, Spreed.ME, show advanced settings and do Generate new shared secret. Copy the value to some opened editor or what, you will need it later. I will call the value Z. Save settings!

  3. Download and unzip spreed server from github to your /opt directory:

$ cd /opt
$ wget
$ unzip
$ cd spreed-webrtc-master

  1. To compile spreed, you need to install some packages, containing to compiler golang-go. Check if the version of golang-go in your repository is at least 1.4, but as I can see here, the version in ubuntu 16.04 lts is at 1.6, so no problem with that.

$ sudo apt-get install git node.js make automake golang-go

  1. Compile

$ ./
$ ./configure
$ make

  1. Create configuration file as copy from example configuration and do some adjustments. For that you need the previously saved Z and two additional random hex values as secrets. I will call them: X and Y.

$ cp server.conf
$ openssl rand -hex 32 => X
$ openssl rand -hex 32 => Y
$ nano server.conf


listen =
root = /opt/spreed-webrtc-master
basePath = /webrtc/


sessionSecret = X
encryptionSecret = Y
authorizeRoomJoin = true
extra = /path/to/nextcloud/apps/spreedme/extra
plugin = extra/static/owncloud.js


enabled = true
mode = sharedsecret
sharedsecret_secret = Z

  1. Add some necessary proxypass to your nextcloud vhost, enable apache modules for that:

$ a2enmod proxy_http proxy_wstunnel headers
$ nano /etc/apache2/sites-available/nextcloud.conf (or whatever your vhost is called)

# Spreed WebRTC config (must be in same vhost)
<Location /webrtc>
        ProxyPassReverse /webrtc
<Location /webrtc/ws>
        ProxyPass ws://
ProxyVia On
ProxyPreserveHost On
RequestHeader set X-Forwarded-Proto 'https' env=HTTPS

$ sudo service apache2 restart

At that stage you should be able to start the spreed server within terminal:

$ cd /opt/spreed-webrtc-master
$ ./spreed-webrtc-server

If the startup is going well you can try to connect to it via Spreed.ME app in nextcloud web ui. Video calls within your local network should also work. Try it out! If there is no partner, just open a second browser instance and join spreedme. You can join it multiple times with the same user and call yourself :smiley:. Good for testing at least.

If you try to do a video call from or to outside your local network, it will most likely fail, because the actual client IPs are hidden behind some router/NAS whatever. You could try to use a STUN server which forwards the local network IPs to allow P2P again. This is quite easy, as spreed itself provides some STUN server. You just need to uncomment the related line in spreed server.conf:

$ nano /opt/spreed-webrtc-master/server.conf

stunURIs =

Sadly in many cases the STUN server is not enough to get video calls working. For that cases I would recommend to directly install an own TURN server, so that all traffic is directed through the TURN server instead of trying to get some P2P connection work.

  1. Install and configure coturn as TURN server from repository, and set spreed server to use it instead of STUN. You will again need some random hex value for that, which I will call A now ;).

$ sudo apt-get install coturn
$ openssl rand -hex 32 => A
$ nano /etc/turnserver.conf


$ nano /opt/spreed-webrtc-master/server.conf

#stunURIs =
turnURIs = turn:<>:8443?transport=udp, turn:<>:8443?transport=tcp
turnSecret = A

$ nano /etc/default/coturn


$ sudo service coturn restart

  1. Open and forward port 8443 (for udp and tcp) in your router to your nextcloud/spreed/turn server.

At this stage, after starting the spreed server in terminal $/opt/spreed-webrtc-master/spreed-webrtc-server again, you should be able to do video calls through any NAS/Router/Firewall setup.

The last step would be to create a systemd unit to autorun the spreed server. Just follow my guide about this: [Spreed.ME] Howto autorun "spreed-webrtc-server" step-by-step
You can actually leave out step 4 (environment file) and add the values there directly to the service file (step 6), which would then look like this:

Description=Spreed WebRTC server
ExecStart=/opt/spreed-webrtc-master/bin/spreed-webrtc-server -c /opt/spreed-webrtc-master/server.conf -l /var/log/spreed.log

Hope I did not forget something. Always do the described tests in between and report if you come across an error.

Thank you!
I will notified you if I miss in one step…