Indiana Timezone breaking Nextcloud :(

Nextcloud version (eg, 18.0.2): 18.0.4
Operating system and version (eg, Ubuntu 20.04): Reclaim Hosting:

uname -a
Linux 3.10.0-962.3.2.lve1.5.27.el7.x86_64 #1 SMP Sat Nov 30 02:18:52 EST 2019 x86_64 x86_64 x86_64 GNU/Linux

Apache or nginx version (eg, Apache 2.4.25): unsure httpd -v does not report anything
PHP version (eg, 7.1): 7.2

The issue you are facing:

I should preface this by saying that I live in Indiana in the US, so we have a fucked up timezone situation. This past week my android phone has also hard crashed and had to be restarted becasue of time zone updates.

I have NC 18.0.4 hosted on Reclaim Hosting, which uses cpanel. All last week I was getting errors that read something like “your locale is invalid, resetting failed please set your locale right.” So I figured I’d try to do a quick fix last night :expressionless:

I ran the self-check thing in settings and it said that NC wanted more RAM in PHP settings, so I did that, and it also said that a bunch of indices were missing, so I ran a command that was something like db:rebuild-indices. Everything seemed fine; but in another tab I set my Locale to English [USA, Computer] (I think), and clicked away. Aaaaaand now it’s inaccessible.

Technical details
Remote Address:
Request ID: XsVHmgzV8fg7tZJqrWETyAAAwA0

it says the logs will have more info, but the logs literally only have the exact above info. I can use a different browser and login, but then I get the, er, blue screen of death I have terminal access through cPanel, but that’s it basically.

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. indiana time zone
  2. less ram than NC likes on PHP, missing a bunch of indices from Reclaim install
  3. follow the aboce

The output of your Nextcloud log in Admin > Logging:


The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'oc2ctrjhieiu',
  'passwordsalt' => 'PW',
  'secret' => 'SECRET',
  'trusted_domains' =>
  array (
    0 => '',
  'datadirectory' => '/home/USER/',
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'USER_nc1',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'nc_',
  'mysql.utf8mb4' => true,
 'dbuser' => 'USER_nc1',
  'dbpassword' => 'X.PWPWPWPWPW',
  'installed' => true,
  'has_rebuilt_cache' => true,
  'app_install_overwrite' =>
  array (
    0 => 'keeporsweep',
  'maintenance' => false,

The output of your Apache/nginx/system log in /var/log/____:


@Thom1 in the IRC came through with recommending that I try

“force_locale” => “en_US”,

I used single ’ 's in order to be consistent and that seems to have fixed the issue. Will I have anything else to worry about—except convincing the whole state to switch to central time?

1 Like