Increase the updater timeout time


I have nextcloud on openwrt of Raspberry PI4. Every time I upgrade the nextcloud to new version, the web updater gives “gateway timeout error” at step “backup” and “download”. This is due to slow writing speed of SD card. Is there a way to increase the timeout time? If yes where to set this time? I am using nginx web server.

I want to increase 10 times of the current timeout setting.


Please use updater.phar

thank you. I did use the command line before, but I still prefer to use web interface. I am GUI-oriented. I think it would be easy to just change the timer. The web updater will complete the update if I keep refreshing after error appears.

1 Like

Ok. But i think cli-updater is better with less errors.

Did you read this issue?

Much and good luck,

The timeout values need to be configured in nginx (fastcgi_read_timeout) and additionally in PHP (max_execution_time and max_input_time).

Thanks for all suggestions. I will increase the timeout and wait for next update.