In IE 10 folder is not showing

I am using nextcloud 10 which is installed in ubuntu apache2 server. I have tried to redirect there from my .net application through IIS. So, i have put some redirect rules in there. It works fine in all browser except IE.
What i am trying to say is that suppose
my nextcloud is :
my .net application:
when i am hitting it is redirecting to without changing the url. In crome, firefox its working fine But in IE remote.php/webdav is getting 400 error which may be the reason for not loading folders. but i can not figure out why this is happening. Please any kind of help will be great. Thanks.

AFAIK IE 10 is unsupported. Use a newer browser

Its not working in any IE version even in edge. Is there any solution available for IE???

@shakhawat no idea, did you try if it even works in other browsers?

Yes. It is working in other browser. Only having problem in IE while it try to propfind request of remote.php/webdev, it is responding with 400 error in response. In other browser its respose with 207.

Ah probably related to the hated intranet mode in IE. Try to turn that off

Still my bad luck continues. No view of folders in IE. Still its having 400 Bad Request

Do you have the same problem when you access the nextcloud-url directly? And

No. I don’t have any problem with direct url. Problem occurs with redirect url. Do i need to change something in IIS rewrite rules???

@shakhawat Windows server is not supported fyi

There are a few parameters you can set in the config/config.php regarding the use of proxies. If the error code is wrong, I would guess it is in your proxy but I don’t know IIS at all. There were a few threads on this forum (or from owncloud which should not differ in that point) where people used IIS. Also have a look into IIS-forums, perhaps someone already had a similar issue.

But it works fine in other browsers except
IE. so IIS is working fine i guess. :frowning:

Can you post the exact response that you get? Including headers and so on.

You can probably copy that from the IE developer tools.

My Request Header:

Request PROPFIND /cl/remote.php/webdav/ HTTP/1.1
Accept /
X-Requested-With XMLHttpRequest
requesttoken exBqMCB2OhAzZzIaKWB0fAEQfQgvDDcwcE4nPzEdPSA=:LdXVnFojAReTX27JWr6oNdgb9zbKIyQxcwxsw1/+dXk=
Depth 1
Content-Type application/xml; charset=utf-8
Accept-Language en-US
Accept-Encoding gzip, deflate
User-Agent Mozilla/5.0 (Windows NT 6.1; WOW64; Trident/7.0; rv:11.0) like Gecko
Content-Length 471
Cookie ocy9r9oj7fyg=j1fnjjbmnk6epubh66n4245ot1; oc_sessionPassphrase=1hP8okZOgjLc4j0%2Bm9dnqayA9wymdT2zBKKkv9XhKntJwPMbsiPTeucbP5%2BWgKQOmqimR5w%2Fm1PhpOsjt6eATgPmDuYQMwvtHRl757%2BOocAygdL%2Bu3gVE9ByyVusm%2BsG; nc_sameSiteCookielax=true; nc_sameSiteCookiestrict=true
Connection Keep-Alive

and response header:
Key Value
Response HTTP/1.1 400 Bad Request
Date Wed, 26 Oct 2016 12:25:58 GMT
Content-Length 318
Connection close
Content-Type text/html; charset=iso-8859-1

And in chrome:
Response header:
Cache-Control:no-store, no-cache, must-revalidateConnection:Keep-AliveContent-Length:7128Content-Security-Policy:default-src ‘none’;Content-Type:application/xml; charset=utf-8Date:Wed, 26 Oct 2016 12:31:23 GMTDAV:1, 3, extended-mkcolExpires:Thu, 19 Nov 1981 08:52:00 GMTKeep-Alive:timeout=15, max=45Pragma:no-cacheServer:Microsoft-IIS/7.5Vary:Brief,PreferX-Content-Type-Options:nosniffX-Download-Options:noopenX-Frame-Options:SameoriginX-Frame-Options:SAMEORIGINX-Permitted-Cross-Domain-Policies:noneX-Powered-By:ASP.NETX-Powered-By:ARR/3.0X-Robots-Tag:noneX-XSS-Protection:1; mode=block

Request Headers view
sourceAccept:*/*Accept-Encoding:gzip, deflate, sdch, brAccept-Language:en-US,en;q=0.8Cache-Control:no-cacheConnection:keep-aliveContent-Length:471Content-Type:application/xml; charset=UTF-8Cookie:DisplayDivasCookiesBanner=yes; nc_sameSiteCookielax=true; nc_sameSiteCookiestrict=true; oc_sessionPassphrase=GgGLivUDxA1hzxgk%2BuFI6q9XqR0Bp5hQwQRrVjKIs4OHBvQ43u49gsmPa8o8rVYhAr7kMGQGK6Xhp677m9kSTCkx%2B4nv1d2S4xJeNYlwUAxyP%2BnOWaMfk1fbInsxyJHE; ocy9r9oj7fyg=k9r0ql2u9ackun7quis0fofc92Depth:1Host:escmid-dev.pulselinks.comOrigin:https://escmid-dev.pulselinks.comPragma:no-cacherequesttoken:BUYWIxodGQVDHRQbF00/GjENFFcGZ08rUDJ8DS8gJXU=:A6EKldRQ7rCNyylYbZSx6Tzx6dHBuynGhF+65Nc3AXM=User-Agent:Mozilla/5.0 (Windows NT 6.1; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.71 Safari/537.36X-Requested-With:XMLHttpRequest

That seems like an IIS configuration error on your end. There’s not much we can do here.

I’d recommend checking the IIS error logs.