In Browser My Files Not Showing..New To NextCloud

Hi Every One I am New To NextCloud.
Before i tried own cloud but i am not satishfied with own cloud.
And thanks Team For giveing this Wonderful NexCloud.

I have installed Nextcloud on google VPS everything works fine but In browser "My Files"
not showing anything. When i login into nextcloud home page.i’ll get error “Connection Server Lost” after this error home page reloading automatically then “my files” shows nothing.
But in Tor browser It working fine.

Imporatnt is nothing show on log files.

NextCloud Version : 12.0.3
OS : Ubuntu 16.04
Web server : Apache2
Database : Mysql
Client Browser Cross Checked : Firefox 56.0 , IE 11.
“My Files” Worked on : TOR Browser 7.0.8

Sounds strange when one browser works and the other doesn’t.
Do you use addons that could influence the web site content? Any blocker?

Could you please clear the browsers cache (via Settings -> “Data protection and Security” -> “Cached Web content”) and perform a full reload (CTRL + F5) of your nextcloud web page afterwards?

Hi schmu
Thanks for your quick response.
I am not using any blocker plugins in my web browser.
I did clear browser cache contents and performed full refresh but not works.
How can solve this error…?
What can i do…?

Please open the browser console (from the developer tools) then and see if there are error messages when you load the files app in nextcloud. Please paste the output here.
Can you tell if there is something else different between Firefox/ IE and Tor Browser apart from being another browser? Are there different settings or is there some special configuration (VPN connection to the network your nextcloud server belongs to) for the Tor browser?

I mean, it can hardly be a server problem when there are browsers that work. Did you test Microsoft Edge - just being curious if that would work.

In my side i am not expert in Tech Field. But i am sure i didn’t any special configuration like VPN,Network Proxy.etc…
In addition Chrome also not working…Unable to post direct links on forum bcz of restrictions so i removed a link & .com from this before link.
This is from Firefox

Shutting down notifications: [0] error merged.js:273:5
_onFetchError Xxxxxxxxxxxxxdotcom/index.php/js/notifications/merged.js:273:5
j xxxxxxxxxxdotcom/core/vendor/core.js:2:26920
fireWith xxxxxxxxxxdotcom/core/vendor/core.js:2:27738
x xxxxxxxxxxxdotcom/core/vendor/core.js:4:11276
b/< xxxxxxxxxxxdotcom/core/vendor/core.js:4:14740
Content Security Policy: Directive ‘frame-src’ has been deprecated. Please use directive ‘child-src’ instead. (unknown)
JQMIGRATE: Migrate is installed, version 1.4.0 core.js:7:542
window.controllers/Controllers is deprecated. Do not use it for UA detection.

This is from Chrome

core.js?v=e7f91f6224aa3e08ad411a9b9e9938b9-10:5722 PROPFIND xxxxxxxxxxdotcom/remote.php/webdav/ net::ERR_CONNECTION_RESET

i am using windows 8.1 and 8 and 7…so unable to test it on microsft edge browser.

Please don’t use /remote.php/webdav/
Remove that from your URL and access your server with yourdomain[dot]com only.

I am using mydomain[do]}com but this is error generated link from brwser console.

For the other users who come across this issue and want to know what solved it at last:
The antivirus solution used by karthikjoe blocked parts of the web traffic from Nextcloud to the clients.
All clients used K7 Endpoint Security.

The Tor browser was the only browser that didn’t allow traffic analysis by the antivirus tool and that is why everything worked fine with this browser.

So if you have a similar problem, deactivating your antivirus or web analysis tool could be one thing to try.

For karthikjoe the issue is solved however.

1 Like

I am encountering the same symptoms as this issue.
Without the antivirus…

Nextcloud 20.0.1 running within FreeNAS-11.3-U5 on internal network…

On my CentOS7 gateway machine, I setup port forwarding

firewall-cmd --zone=public --add-masquerade
firewall-cmd --zone=public --add-forward-port=port=80:proto=tcp:toport=8282:toaddr=

firewall-cmd --zone=public --list-all
public (active)
target: default
icmp-block-inversion: no
interfaces: enp2s2 enp2s6
services: openvpn ssh http https
masquerade: yes
forward-ports: port=80:proto=tcp:toport=8282:toaddr=
rich rules:

Nextcloud seems to be fine, however,
Google Chrome on windows 10, Chrome on IOS, & MS Edge
I can login, click folders,
File list, spins and spins, no content,
x Connection to server lost.

Chrome developer tools/Console reports
Failed to load resource net::ERR_CONNECTION_RESET
PROPFIND http:///remote.php/dav/files//Documents

NOW, when I use an ssh_tunnel instead, same ports, same gateway etc,
It works a-ok, no errors… ???
Trying to figure out what the port-forwarding is not doing correctly…

Need to use allowed external facing ports (such as 80/443)
and would rather not have collaborators need to use ssh_tunnel to access.
(ultimately I will move to https.)

I’m thinking it’s the CentOS port forwarding/masquerade and/or reverse proxy
issue… and whats different than using say a lynksys router gateway to port forward,
which I have not tried yet…

any suggestions ?


The solution for me in this case was actually using the https port. For some reason the university FW/Gateway is stopping part of port 80 traffic, perhaps too many 301 redirects ? Not sure, When I applied the ssl cert and started using https, things were fine. (as it also always worked with an ssh/tunnel, but I didn’t want users to have to do that.) So, my advice in this situation is check with the FW limiting factors, and, always safer to use https anyway.