Impossible to remove a contact

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:


Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 22.2.4
Operating system and version (eg, Ubuntu 20.04): debian 11
Apache or nginx version (eg, Apache 2.4.25): nginx/1.18.0
PHP version (eg, 7.4): 7.3

The issue you are facing: Impossible to remove a contact that I have been enter before

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. In contact I clic on remove contact
  2. Error impossible to remore the contact
  3. The contact isn’t removed

The output of your Nextcloud log in Admin > Logging:

I see nothing about this on the Admin > Logging

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'default_phone_region' => 'FR',
  'instanceid' => 'ocazertyuiop',
  'passwordsalt' => 'azertyuiopqsdfghjklmwxcvbnazer',
  'secret' => 'eerrttyyuu6JKImnBb6sXVPFThmm4CGs2eODzEG23dpzpRO6',
  'trusted_domains' => 
  array (
    0 => '',
  'datadirectory' => '/var/www/'
  'dbtype' => 'mysql',
  'version' => '',
  'overwrite.cli.url' => '',
  'dbname' => 'name',
  'dbhost' => 'localhost',
  'dbport' => '',
  'dbtableprefix' => 'oc_',
  'mysql.utf8mb4' => true,
  'dbuser' => 'user',
  'dbpassword' => 'dbpassword',
  'installed' => true,
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_from_address' => 'contact',
  'mail_domain' => '',
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 2,
  'mail_smtpsecure' => 'ssl',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '',
  'mail_smtpport' => '465',
  'mail_smtpname' => '',
  'mail_smtppassword' => 'password',
  'memcache.local' => '\\OC\\Memcache\\Memcached',
  'updater.secret' => '$ertyu$sX5peIjimMlgP/VCQzZ.JuqCtLybbd/UTR86csegiPq.57Pz49

The output of your nginx log in /var/log/____:

2022/01/31 09:29:32 [error] 3954698#3954698: *230551 [client x.X.X.X] ModSecurity: Access denied with code 400 (phase 2). Matched "Operator `Eq' with parameter `0' against variable `REQBODY_ERROR' (Value: `1' ) [file "/etc/nginx/modsec/modsecurity.conf"] [line "65"] [id "200002"] [rev ""] [msg "Failed to parse request body."] [data "XML parsing error: XML: Failed parsing document."] [severity "2"] [ver ""] [maturity "0"] [accuracy "0"] [hostname "X.X.X.X"] [uri "/remote.php/dav/addressbooks/users/moi/contacts/DC94F648-1C76-48A1-8517-14C9A0374CA4.vcf"] [unique_id "1643617772"] [ref "v1029,1"], client: X.X.X.X, server:, request: "DELETE /remote.php/dav/addressbooks/users/moi/contacts/DC94F648-1C76-48A1-8517-14C9A0374CA4.vcf HTTP/2.0", host: ""


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.