Impossible to read .ods or .odt files in my nextcloud

Hi, though the app is installed an up to date, I can’t read ods nor odt files in my nextcloud. An error message appears and I can read ‘internal error’.
Anyone dif fix that before? Thanks.

have you installed the server-version of the needed software as well?

it would be best if you’d give everyone a bit mo’ information about your environment you’re running. and which app exactly ain’t doing it’s job

Hi,
I use Nextcloud 12 on my raspberry pi2b working since yesterday :slight_smile: : raspbian Jessie Lite + serveur web LAMP (Linux Apache Mariadb PHP). Everything is ok except sending emails (but it’s gonna be another post later )
it seems to be CollaboraOnline that doesn’t work. When I uninstall it it doesn’t try to read it and only download the file. When activated I’ve got the error message. I tried too onlyoffice in the apps and no way to read Office documents.
I just can use Markdown editor to edit txt ans md files without difficulty (and it’s great)
I tried it through my nextcloud website with ubuntu 16.04 (Firefox) , MACOS El Capitan (Safari).

As far as I know the NC apps “Onlyoffice” and “CollaboraOnline” are no full featured applications but only interfaces for the corresponding server-version of the software which must be installed separately.

1 Like

thanks for providing us with more information. and so it came apparent that my first thought (out of the blue) was indeed the right one. since you need to install the server-versions of “onlyoffice” and/or “collabora online” somewhere in your local-lan and then point to it with the referring NC-app. (see what @Hollerauer said above)
both apps alone won’t work - as far as i know.
so you better read the manuals of both apps to find out how to proceed further.

Thanks a lot for your advices. I am going to follow these steps. Have a nice day !

purrrrfect…
and in case you succeeded - pls don’t hesitate to mark this thread as “solved” :wink: