Import Paid SSL Certificate on Nexcloud

Hi, We recently starting to use nextcloud server. I installed nextcloud with snap library. We gave static ip to open all to connect external user and share their files. And then we changed to domain name (10.34.100…-> . After we bought comodo ssl certificate. I’d like to import this .crt file and do not want to take any security error while we access to website.

How can I import ssl certificate? And If I repeat “sudo nextcloud.enable-https lets-encrypt” this process would I have a chance to not lose data and return the site alive?

There is so many work free ssl with letsencrypt, certboot but could not find related with paid ssl cert. Also comodo ssl give me this all crt and txt files. Not give me any pem etc. Can you help me to our ssl to activate.


Resource about install nextcloud ;

Nextcloud Version : 20.0.1 System Report
Password: tVdN4bbxaeUDR9RIApQM

Ubuntu 20.04 LTS Desktop Version

Hello @bahadirsoybakis,

welcome to the community of Nextcloud.

You started a topic in support category.

Unfortunately you ignored the template and a lot of information to help you is missing.

Please add all necessary information like Nextcloud version, webserver type and version, os version.

Without additional information the community members cannot help you .

it says that you should run the command with -h for more options. And in the sources I found this line:

Thanks @tflidd. I need to write about such as

nextcloud.enable-https custom cert.pem key.pem cert.pem

but I have just .crt files. After I generated pem and key files with rsa; Do you mind if I use the same .pem files? Or How can I generate them.

Hey @bahadirsoybakis
could you solve the probleme? I have the same issue with the same certs.
It would be nice to see how you solved it.



With snap deployment, it’s pretty simple to install a paid certificate.

Step One

Copy the certificate files, (cert file, pvtkey file and chain file) in a directory like /var/snap/nextcloud/current/certs/custom/

Step Two

Run following command with sudo, make sure to change the name of the cert files as per your own while staying with same directory as the location of the files.

cd /var/snap/nextcloud/current/certs/custom/
sudo nextcloud.enable-https custom -s cert.pem privkey.pem chain.pem

This will enable the https and setup will work via port 443

I have the done the same with my installation and worked fine.


if already found it BUT it won´t work for me and I just dont know why @bahadirsoybakis is using the exact same ca issuer then me so it would be perfect to hear from what he did to solve the probleme.

I am about to replace the let’sencrypt with a paid one, I will try this:

Hope it helps.