Ihr Webserver ist nicht richtig konfiguriert um "/.well-known/caldav" & "/.well-known/carddav" aufzulösen. Weitere Informationen hierzu finden Sie in unserer

Hi Zusammen, ich bin ein Newby in Sachen nextcloud und mir fehlt auch die Erfahrung mit Linux.
Ich habe die offene Sicherheits- und Einrichtungswarnungen:

Was habe ich am laufen (Eckdaten vom System und von NC):

  • OS: Linux Ubuntu 22.04.2 LTS
  • Eigene VM auf meinem QNAP-Server
  • Nextcloud als LAMP installiert
  • Architektur: Vorangestellt ist der NGINX-Reverse Proxy Manager. Hierüber wird NC via HTTPS erfolgreich aufgerufen.
  • der Apache-Webserver:
    - liegt unter /etc/apache2
    - unter /etc/apache2/sites-available gibt es folgende beiden Dateien:

image

In den verschiedenen Dokumentation liest man einmal von den beiden Datein 000-default.conf und default-ssl.conf, in anderen Dokus liest man dann wieder von einer nextcloud.conf. Kann mir hier mal jemand evtl. erklären, welche .conf-Datei welchen Zweck hat, und welche ich überhaupt wirklich benötige? Wäre cool :slight_smile:

Meine Nextcloud-Installation liegt und /var/www/nextcloud
Meine Nextcloud-Daten liegen unter /home/data

Mit der Anleitung, auf die in NC referenziert wird Link zur Anleitung, kann ich nur wenig anfangen.

Kann mir hier jemand vielleicht transparent für einen Newby ein paar Hilfestellungen geben, wie ich das ganze Webapplikationskonstrukt customizen muss, damit die Warnungen verschwinden, bzw. was sich hinter den einzelnen .conf und .ini Dateien verbirgt?

Beste Grüße Coleman

You need to put the following paths in the custom locations tab.

Click add location

Define location >> /.well-known/caldav
Forward Hostname / IP >> 127.0.0.1/remote.php/dav/

Click add location

Define location >> /.well-known/carddav
Forward Hostname / IP >> 127.0.0.1/remote.php/dav/

Click add location

Define location >> /
Forward Hostname / IP >> 127.0.0.1/

Hope this helps you.

Hi Edson,

thanks for help.
Can you describe me what do you mean with custom location tab?

My Nextcloud is installed in directory /var/www/nextcloudprod and my Apache Webserver is installed in directory /etc/apache2.

According official Nextcloud documentation I only have to adjust the .htaccess-File in /var/www/nextcloudprod like this:

I did that in the following yellow marked way:

After reboot of the whole virtual machine it nevertheless doesn’t work.

What do I wrong, what is missing?

Greetings Coleman

Guten Tag!
Ich hoffe, es ist in Ordnung, wenn ich an dieser Stelle antworte.

Für und hat folgendes bis jetzt (fast) immer funktioniert:

Erstelle die Datei

sudo nano /etc/apache2/sites-enabled/000-default-le-ssl.conf

Dort musst du folgenden Inhalt einfügen:

<IfModule mod_headers.c>
 Header always set Strict-Transport-Security "max-age=15552000; includeSubDomains; strict-origin; preload"
 Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
 Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav
 Redirect 301 /.well-known/webfinger /nextcloud/index.php/.well-known/webfinger
 Redirect 301 /.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo
</IfModule>

Melde dich gerne nochmal bei Fragen!

Bei weiteren Einrichtungsproblemen kannst du dich unter
https://technik.schächner.de/blog/2022/08/05/sicherheits-und-einrichtungswarnungen-nextcloud/ informieren.

Viele Grüße!

1 Like

Dank Dir, ich schau’s mir gleich mal an.

Grüße
Coleman

Wenn du weitere Fragen zu Erklärungen / … hast einfach melden!

Hi Vinzenz,
jetzt hab ich mir Deine wirklich transparente Seite angeschaut und auch versucht folgenden Step in meine Architektur zu integrieren - bei mir leider ohne Erfolg

Vielleicht aber erst kurz für Dich zur allgemeinen Info, wie ich die SSL-Verschlüsselung bei mir erfolgreich realisiert habe:
Ich hab nen NGINX-Proxymanager der mir meine Nextcloud via SSL extern verfügbar macht. Ich redirekte von diesem auf meine Nextcloud auf die normale interne HTTP-/IP-Adresse. Da ich keine direkte SSL-Verschlüsselung in der Nextcloud via Certbot mache, nutze ich bisher die Default-Apache-Konfigurationsdatei etc/apache2/sites-enabled/000-default.conf.

Diese sieht vor meinen Anpassungsversuch anhand Deiner vorgeschlagenen Konfiguration…


…wie folgt aus:

Dann habe ich meine Konfiguration in Anlehnung an Deine Konfigurationsinfos in dieser Datei /etc/apache2/sites-enabled/000-default.conf entsprechend angepasst.

  • Mein DocumentRoot-Verzeichnis meiner Nextcloud ist /var/www/nextcloudprod
  • Mein Apache-Webserver liegt unter /etc/apache2

Nach den Anpassungen in der 000-default.conf und dem Neustart des Apache-Webservers, als auch noch zusätzlich nach dem Reboot der kompletten VM sehen die Sicherheits- und Einrichtungswarnungen in der Nextcloud weiterhin so aus:

→ Es hat also nicht den gewünschten Erfolg gebracht.

So sieht im Übrigen meine /var/www/nextcloudprod/config/config.php aus:

Hast Du mir einen Tipp, was ich falsch mache? Wäre klasse :slight_smile:

Grüße Coleman

Ich kämpfe immer wieder mit diesem Problem und bekomme das auch nicht wirklich in den Griff weil es auch wenn es dann doch funktioniert irgendwann wieder auftaucht. Aber ich denke, in diesem Fall könnte das Problem der Pfad des Verweises sein.
Das Rootverzeichnis des Webservers ist hier “/var/www” und sollte wohl nicht auch noch in dieser Config mit angegeben werden.

1 Like

Hi Gerry,
erstmal danke für den Tipp. Leider hat die Anpassung auch keinen Erfolg mit sich gebracht. Habe sowohl den Webserver, als auch nachfolgend noch die ganze VM neu gestartet. Ich habe folgende Varianten in der 000-default.conf versucht:

Beide haben nicht den gewünschten Erfolg mit sich gebracht. Hoffe, ich habe Dich richtig verstanden?!
Trotzdem danke für den Tipp! :slight_smile:
Coleman

Ich habe nun eine Teillösung hinbekommen, indem ich bei meinem NGINX-Proxymanager Eintrag unter Advanced das im folgenden Screenshot hinterlegten Einträge eingetragen habe:


Dadurch sind die Warnungen von CALDAV und CARDDAV (grün hinterlegte) verschwunden!
Das gelb hinterlegte habe ich ebenfalls dort eingetragen, allerdings bleiben die beiden Warneinträge WEBFINGER und NODEINFO in Nextcloud bestehen.

Kann sich da jemand nen Reim drauf machen…hmmm?

Hier ist die Lösung für das Problem. Im NGINX-Proxymanager muss Folgendes eingetragen werden:


grafik

Des Weiteren müssen die Einträge im NGINX-Eintrag unter dem Tab Advanced, also Folgende, wieder gelöscht werden:

location /.well-known/carddav {
return 301 $scheme://$host/remote.php/dav;
}

location /.well-known/caldav {
return 301 $scheme://$host/remote.php/dav;
}

location /.well-known/webfinger {
return 301 $scheme://$host/index.php/.well-known/webfinger;
}

location /.well-known/nodeinfo {
return 301 $scheme://$host/index.php/.well-known/nodeinfo;
}

@Gerry hat mit dem Document Root recht gehabt. Den solltest du (wenn du es nicht schon gemacht hast) auf /var/www/ umändern.
Nur als „Kleinigkeit", die aber nichts ausmacht:
Wenn du den Dokument Root auf /var/www/ stellst, benötigst du bei den Zeilen
Redirect 301 /.well-known/webfinger /nextcloudprod/index.php/.well-known/… noch den Ordner “nextcloudprod”. Wenn du den Dokument Root auf
/var/www/nextcloudprod
stellst, kannst du das weglassen.

Mit Nginx haben wir tatsächlich noch nicht so viel gearbeitet, ab Respekt, dass du die Lösung gefunden hast. Das hilft sicher vielen!

Einen schönen Abend und an alle: Nicht aufgeben :upside_down_face: