Ihr Webserver ist nicht richtig konfiguriert um "/.well-known/caldav" aufzulösen

Hallo,

ich hab ein Problem was ich seid mehreren Tagen nicht gelöst bekomme.
Es geht um folgendes.
Im Browser unter der “Übersicht” wird mir das angezeigt:

  • Ihr Webserver ist nicht richtig konfiguriert um “/.well-known/webfinger” aufzulösen. Weitere Informationen hierzu finden Sie in unserer Dokumentation :arrow_upper_right:.
  • Ihr Webserver ist nicht richtig konfiguriert um “/.well-known/nodeinfo” aufzulösen. Weitere Informationen hierzu finden Sie in unserer Dokumentation :arrow_upper_right:.
  • Ihr Webserver ist nicht richtig konfiguriert um “/.well-known/caldav” aufzulösen. Weitere Informationen hierzu finden Sie in unserer Dokumentation :arrow_upper_right:.
  • Ihr Webserver ist nicht richtig konfiguriert um “/.well-known/carddav” aufzulösen. Weitere Informationen hierzu finden Sie in unserer Dokumentation :arrow_upper_right:.

Natürlich hab ich erstmal versucht mit nach den Docs zu richten und habe versucht selber das Problem zu lösen allerdings scheint nichts zu funktionieren.

Systeminformationen:
Hardware: Raspberry Pi 3b+
OS: Rasbian
PHP Version: PHP 8.0.9
Nextcloud Version: 22.1.0
Web-Server: Apache2.4.38
Datenbank: MySQL (Version: 10.3.29 MariaDB)

Ich hoffe ich habe nichts vergessen solltet ihr dennoch was brauchen um mir zu helfen fragt nach ich kanns euch schicken.
Außerdem hoffe ich das ihr eine Lösung habt da ich die Probleme doch sehr gerne gelöst hätte.

Gelöst

würdest du das in eine eigene Antwort zum Thema verschieben, bekämst du deinen ersten “gelöst”-Award (obwohl das hier im Forum hoch und runter diskutiert wurde) :wink:

Gelöst
Musste:

Redirect 301 /.well-known/carddav /nextcloud/remote.php/dav
 Redirect 301 /.well-known/caldav /nextcloud/remote.php/dav
 Redirect 301 /.well-known/webfinger /nextcloud/index.php/.well-known/webfinger
 Redirect 301 /.well-known/nodeinfo /nextcloud/index.php/.well-known/nodeinfo

zu /etc/apache2/sites-enabled/000-default-le-ssl.confg hinzufügen. Hatte wohl vorher etwas vergeigt. :slight_smile:

2 Likes

Vielen dank :slight_smile:

Hallo wo muss das hinein bzw wie muss der pfad aussehen wenn mein pfad so ist:

/var/www/vhosts/dodux.de/httpdocs/cloud

Das hängt davon ab, was im vHost des Apache als DocumentRoot eingetragen ist.

magst du mir einen tipp geben wie ich das finde?

Die Nextcloud-Doku sollte alles hergeben, was notwendig ist: https://docs.nextcloud.com/server/latest/admin_manual/installation/source_installation.html#apache-web-server-configuration