Icons not loading/showing


I’m running nextcloud 14.0.0 within docker. Since some time I’m facing the problem that some icons (folder icon, shared folder icon and my avatar in the upper right corner) are not showing.

When inspecting with chromium I get the following errors:
GET https://mydomain/index.php/avatar/myuser/32?v=0 net::ERR_SPDY_PROTOCOL_ERROR 201
GET https://mydomain/index.php/apps/theming/img/core/filetypes/folder-shared.svg?v=0 net::ERR_SPDY_PROTOCOL_ERROR 200
GET https://mydomain/index.php/apps/theming/img/core/filetypes/folder.svg?v=0 net::ERR_SPDY_PROTOCOL_ERROR 200

Anyone experienced this problem before?

Thanks in advance!

Do I need to add more information?

Updated to 14.0.1, no change. Problem exists as before.

Problem still exists with 15.02

Did you resolve your issue? I have a similar one when i load site using SSL, but http icons are ok

Same problem here with NC 16. Problem showed up with last upgrade, it was ok before, and I have it in two installs, same hosting, On a third install, same hosting, it’s OK.

I’ve tried disabling all the apps, but problem persists.

r u guys maybe running a personalized theming?

I disabled also the theming app, and nothing changed.
I found this:

which led me to discover that the problem is the same:
https://mynext.cloud/index.php/css/icons/icons-vars.css cannot be loaded.
The file is of course present under my data dir, where it should be.
The problem should have been fixed with the fix proposed here

but doesn’t seem to work, the problem should be somewhere else…

please file a new issue under github and refer to the one posted above.

and please don’t miss linking the new issue here to the forum.

i am sorry but this will “solve” the thread at our forum. not in a good way, though. i know :frowning:

It seems I solved my issue.
My NC is hosted on OVH shared hosting, and I had PHP instead of PHPCGI in the configuration.
Switching back to PHPCGI instantly solved the issue.
Hope this is useful for others too!

I had a similar problem out of nowhere: some icons just disappeared. I’ve solved by downloading the newer docker image (from 20.0.6 to 20.0.8)