I see "RedisException" when trying to use occ

I have long time avoided to upgrade my Nextcloud, because i always get warnings like:

Your web server is not properly set up to resolve “/ocm-provider/”.


Your web server is not properly set up to resolve “/.well-known/caldav”.

Now I want to upgrade, but bevor want to eleminate those warning by using occ. But if I use this command:

webadmin@Wolke7:~$ php /media/DATA-SERVER/www/webseiten/nextcloud/occ -h

I get:

RedisException: Redis server went away in /var/www/nextcloud/lib/private/Memcache/Redis.php:54
Stack trace:
#0 /var/www/nextcloud/lib/private/Memcache/Redis.php(54): Redis->get('4b3e7969ab1bcb9...')
#1 /var/www/nextcloud/lib/private/App/InfoParser.php(57): OC\Memcache\Redis->get('/var/www/nextcl...')
#2 /var/www/nextcloud/lib/private/App/AppManager.php(380): OC\App\InfoParser->parse('/var/www/nextcl...')
#3 /var/www/nextcloud/lib/private/legacy/app.php(551): OC\App\AppManager->getAppInfo('files', false, NULL)
#4 /var/www/nextcloud/lib/private/AppFramework/App.php(65): OC_App::getAppInfo('files')
#5 /var/www/nextcloud/lib/private/legacy/app.php(236): OC\AppFramework\App::buildAppNamespace('files')
#6 /var/www/nextcloud/lib/private/legacy/app.php(119): OC_App::registerAutoloading('files', '/var/www/nextcl...')
#7 /var/www/nextcloud/lib/base.php(654): OC_App::loadApps(Array)
#8 /var/www/nextcloud/lib/base.php(1068): OC::init()
#9 /var/www/nextcloud/console.php(46): require_once('/var/www/nextcl...')
#10 /var/www/nextcloud/occ(11): require_once('/var/www/nextcl...')
#11 {main}webadmin@Wolke7:~$ 

But the server is working very good an if I call

systemctl status redis

I get:

   Loaded: loaded (/lib/systemd/system/redis-server.service; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2020-07-20 04:00:56 CEST; 3 months 25 days ago
     Docs: http://redis.io/documentation,
 Main PID: 1949 (redis-server)
   CGroup: /system.slice/redis-server.service
           └─1949 /usr/bin/redis-server

I’m clueless, as what to do …

nextcloud.log shows nothing related to this message
nc-error shows nothing

My Nextcloud-Version: 15.0.5
and my OS: 4.14.150-odroidxu

Any advice, what to do?


Perhaps redis is not configured right in the config-file?

The other two are more related to your webserver configuration, it’s possible that Nextcloud can’t fix it by itself. It shouldn’t affect the upgrades. I’d upgrade first and then tackle these issues.

I found out by accident, because I tried to call occ again, but then was root und the error-message told me:

Console has to be executed with the user that owns the file config/config.php
Current user: root
Owner of config.php: www-data
Try adding 'sudo -u www-data ' to the beginning of the command (without the single quotes)

Shit, yes! I called occ as www-data and that worked without any error-message. I do not know, why the error-message from obove ist posted, it has nothing to do with any server-fault. Redis is working fine, if Redis does not work, the server is not working. Had that already

Now I#m at loss because I am not able to terminate to messages:

Your web server is not properly set up to resolve "/ocm-provider/"
Your web server is not properly set up to resolve "/ocs-provider/"

Seem, that it’s not possible with Apache …

I’ll try an upgrade with error-messages.