I thought that this problem was solved, but it recurred this morning. I thought that this problem was solved, but it recurred this morning. From the previous experience, I may resolve it naturally if time passes.
My setting of MySQL seems not to solve the problem this time. I saw the server error log, but at least there is no error log of today.
In addition to that, “internal server error” has occurred today. It takes about 40 seconds to log in and an internal error occurs. There is no error number. An internal error occurs only when the login is successful.
Internal Server Error
The server encountered an internal error and was unable to complete your request.
Please contact the server administrator if this error reappears multiple times, please include the technical details below in your report.
More details can be found in the server log.
There seems to be no error in the server’s log, but when I look at the log of Nextcloud it seems there are some errors.
Doctrine\DBAL\Exception\DriverException: An exception occurred while executing ‘SELECT id, numeric_id, available, last_checked FROM oc_storages WHERE id IN (?)’ with params [“local::/var/www/vhosts/NEXTCLOUD/data/”]: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away
Doctrine\DBAL\Exception\DriverException: An exception occurred while executing ‘SELECT uid, password FROM oc_users WHERE LOWER(uid) = LOWER(?)’ with params [“USERNAME”]: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away
Doctrine\DBAL\Exception\DriverException: An exception occurred while executing ‘SELECT id, uid, login_name, password, name, type, remember, token, last_activity, last_check, scope FROM oc_authtoken WHERE token = ?’ with params [“f2a65a6da20e5863f62936d6b6b52dc309cb7855f3bd2186052ec5b91c6a66cdaa7e5ffdcc93c3c2f7f8be5b478e5c0a2ad25a2d82d699c23066d05a80a4db79”]: SQLSTATE[HY000]: General error: 2006 MySQL server has gone away
*There are cases of errors and fatal cases.
There is no error in MariaDB’s log.
What I have in common with the last time, I will not improve even if I reboot the server. MariaDB, nginx, PHP-FPM, these restarts are also ineffective.
When restoring to the original my.cnf that was backed up at that time, no internal server error seems to occur. Login takes time, but no internal error occurs. Is MySQL the cause of the problem?