I get smbclient" is not installed. Mounting of "SMB/CIFS", "SMB/CIFS using OC login" is not possible when I tryy to add an extrenal storage

Hello guys, I have followed all the topics but I have not got a solution yet and I will appreciate your help.
Once I try to add an external 2 tb drive which is mounted in /dev/sda1 /mnt/nextcloud,
I got the red icon with an error:
“smbclient” is not installed. Mounting of “SMB/CIFS”, “SMB/CIFS using OC login” is not possible. Please ask your system administrator to install it.

I have installed nextcloud using docker with raspberrypi 4

I have given permission 777
I have installed
apt-get install smbclient
apt-get install php-smbclient

I assumed that I dont have to configure samba, isn’t it? it is just installed, isn’t it?
if I have to configure, what settings do I need for that fodler?

guys, i really need your help, any logs you suggest, any idea, it is the only missing part to use nextcloud I need to complete

I will appreciate any help
thanks
Jose

My configuration here below

Guys I have installed netxcloud in raspberry pi 4 using docker
This is my procedure:
#sudo apt-get update
#sudo apt-get upgrade
#sudo apt install docker docker-compose

Then, I have connected 2 tb drive and I have mounted in /mnt/nextcloud folder
I gave chmod a+wrx nextcloud al permissions
In that folder I created the docker-composer.yml file . Please, follow below:
version: “3”
services:
nextcloud:
image: nextcloud
container_name: nextcloud
environment:
- PUID=1000
- PGID=1000
- TZ=Europe/Madrid
volumes:
- ./nextcloud/config:/config
- ./nextcloud/data:/data
ports:
- 8082:80
depends_on:
- mariadb
mariadb:
image: linuxserver/mariadb
container_name: mariadb
environment:
- PUID=1000
- PGID=1000
MYSQL_ROOT_PASSWORD=Caja123
- TZ=America/Toronto
- MYSQL_DATABASE=nextcloud
- MYSQL_USER=nextcloud
- MYSQL_PASSWORD=Caja123
volumes:
- ./mariadb/config:/config
ports:
- 3306:3306
restart: unless-stopped

then, Run the command:

sudo docker-compose up -d

And I can open the web and configure mariadb account

I have installed also:
apt-get install smbclient
apt-get install php-smbclient

nextcloudrd

Hi,

My works and I normally run the following commands on the nextcloud container.

apt update && apt -y install libsmbclient-dev libmagickwand-dev && pecl install smbclient && echo “extension=smbclient.so” > /usr/local/etc/php/conf.d/docker-php-ext-smbclient.ini && pecl install inotify

Hello sir, I am a little bit confused about all these sets of updates. What is the relationship between this update and the error when I try to add external storage? the question is because I think this error is more related to some sort of permission between the user that I am using in the nextcloud web and the point of the mount in linux(maybe I am wrong) or this is also related to a some sort of samba configuration needed in nextcloud to allow add storage device as a local. Could you please elaborate a little bit more about your suggestion?

The error about smbclient isn’t probably relevant. You’re looking at the wrong thing. You have the red exclamation mark, because that location (/mnt/nextcloud) doesn’t exist in that docker container. The docker container has its own filesystem. You should add a volume like this, I think:

volumes:
 -/mnt/nextcloud:/mnt/nextcloud

That should be correct according to the docs: https://docs.docker.com/compose/compose-file/compose-file-v3/#volumes

You can ignore the warning, as your storage is local. If you make that modification to your docker-compose.yml, the red exclamation mark should disappear. If it worked, don’t forget to mark this comment as a solution, so other people can see it if they have the same problem.

Forgot to mention you, @josesalazmit