I cant seem to change my server to HTTPS

I have been looking but I haven’t been able to find a way to change the domain from HTTP to HTTPS. I used snap store to install Nextcloud.


Nextcloud won’t do it. You need to set up security certificates the modify Apache config file for the domain.

You can get security certificates at no cost by using Let’s Encrypt (https://letsencrypt.org/).

Once you get those setup, you need to change domain.conf in the Apache sites-enabled directory.

<VirtualHost *:80> # Force SSL (https://)
ServerName yourdomain.tld
Redirect permanent “/” “yourdomain.tld/”

<VirtualHost *:443>

SSLEngine On #Enable and configure SSL
SSLCertificateFile /etc/letsencrypt/live/yourdomain.tld/fullchain.pem
SSLCertificateKeyFile /etc/letsencrypt/live/yourdomain.tld/privkey.pem


Note that you must use port 443 for it all to work.

Hope this helps.


1 Like