I can't save personal account information - Failed to perform action

There was no problem when I first installed it.
I uninstalled nextcloud once. And reinstalled.

Problems occurring to me.
When I log in to my account, I always see ‘Nextcloud’ s initial guide panel '. I make multiple accounts, and it is the same for any account.
When I click on Nextcloud notification, “Failed to perform action” is displayed.

I will proceed to the setting items of personal information and edit each item.
At this time the name seems to be preserved. However, it is not saved by editing an e-mail or telephone number field. Previously I was asked to enter the password at that time, but now I can not ask for the password.

Other than that it seems to be preserved. For example the theming item in the setting of nextcloud. Activity of personal information (mail send setting) etc.

I will not improve at all if I uninstall nextcloud again and then reinstall. Of course, MySQL database is also deleted.
I do not improve even if I set the server (Apache, nginx, php, etc.) setting back to the point where I can return step by step.

Which one should I fix?

Nextcloud version (eg, 10.0.2):12.0.0
Operating system and version (eg, Ubuntu 16.04): CentOS 7.3
Apache or nginx version (eg, Apache 2.4.25): 2.4.6
PHP version (eg, 5.6): 7.1

Can you check your nextcloud logfile? Also open your Browser web developer tools, after you change the settings it should normally send a query to your server and perhaps it is showing you a more detailed error.

I was Apache. Then I changed to nginx (1.10).
In the case of nginx, file list can not be displayed. Contrary to the problem, personal information could be saved.
I adjusted a lot of permissions, groups and owners. However, I do not see the file list anyway. Actually exists.Total “Apache” looks better. How do I improve personal information and Notification?

Thank you for replay.

I seem to be generating a 403 error after I’ve operated something while watching the console using browser developer tools. Even if I set the permissions of all files and directories to “777”, there is no change. I will not change even if I disable all server firewall system.

It seems that a problem has occurred due to some denial response.
Is this a problem with the server’s internal configuration?
httpd.conf, php.ini, nginx.conf. I tried initializing these, but this does not change state either.
What else is there?

I tried the nginx environment again. The step I did was exactly the same as before but seems to be able to build normally this time.
Eventually I couldn’t find the cause of the problem.
Thank you for reading this thread.

What file created the 403 error? Did you use the configuration example for nginx from the documentation?

Thank you.
This problem was resolved with a brute force reinstall. I changed the installed value of config.php to false and initialized MySQL data. This starts the installation process.
I got a MySQL error at the time of this installation and made a new database. It seems that the previous database was broken. I don’t know the cause.