I cant login, the buttons do not do anything

i dont know what to try anymore…

My Phone is a Sony XYZ1 Compact, Android 9.

I run apache2, php8.2 fpm and nextcloud in a subdir bla.noip.tld/nextcloud
On the server side nothing special is logged.

Taking any NC app that directly logs into nc.
I type the address into the field and click next,
then the mini browser pops up the login page, with no fields for credentials,
but an orange warning if i were not trying to log in, to not continue and so on.
Beneath it there is the “Anmelden” / Login Button, and beneath that “alt. log in via app token”.
Either Button does not work.

The NC Dev app has the qr code reader button. I could only log in with a qr code generated in a browser on a computer.

I would like to see what errors are logged in the browser console, or whats going on but i dont how to look at those.
From what i found on the internet it should be some browser protection disabling the buttons.
I disabled my headers for csp and whatnot but that did not help.

If you have any ideas what to try or look at, id like to hear.

it works again. it was some cached bs in the app

Hi, how did you fixed it? I cleared the cache from app menu in android but still have the issue.

I encountered another episode of hidden/nonfunctional buttons.
This time it was an old version of the chrome/integrated browser. after updating it, the site worked.