I cant install it on Win 10, looking for nextcloud.cab


I am unable to install the Nextcloud Windows app on Windows 10. It is looking for a file called Nextcloud.cab and it cant find it.

How do I install it?


There are too many informations about your downloaded package, so we cannot get an overview :wink:

I have never tried this, but I seem to remember them saying that Nextcloud does not run on Windows.

What information can I provide you extra? I am trying to install the desktop client on Windows 10. It is refusing to install and throwing me the message above.

Windows 10

The .msi file I use is fine because I am able to install it on Windows 11. I used to have Nextcloud on Windows 10 long ago but I uninstalled it back then. I am just trying to install it again. I do not know why it it looking for a file called Nextcloud.cab and why it cant find it.

My first opinion is, that you anti virus software might remove the cab file after unpacking the MSI. You may find a log entry in the logfile of the anti virus software.

Does the problem persist, if you install an older version or from the .exe file?

Thanks for the reply. I do not use an antivirus software.

The latest versions that was distributed as .exe was 3.1.3 and I found it in their release repository. I am able to install that one but that one is over a year older vs the current version 3.5.1

3.1.3 seems to regularly crash after synching for a while. I am using it with Nextcloud 22.2.3 on Debian/Apache/Mariadb

What about Windows Defender? - It also may remove obviously infected files.

It is enabled, but I am not sure why it would have removed it. Basically I uninstalled it at some point and I tried to install it again using the .msi file. Is there a way to pass this .cab complaint?

Didn’t you download the Windows desktop client from the official download page?

Yes, that is not the issue. Please see the image I attached in the first post.

It says the file is corrupt.

Did you check the crc already?

It says corrupt but I believe it cant find the file, it seems like it is looking for a .cab file from the past installs?

Probably the installer don’t want to run on a network drive?

DId you try to run that file from your C:\ drive?

1 Like

That was it, thank you.

1 Like