I cant get Talk to work

turn
#1

I want to use the Talk App (latest version) with my Nextcloud (V15.0.7 = latest).
Messaging always works (as expected) but Calling only in the local network (as expected).
Calling does not work on cellular data with my phone.
To use it outside the local network i have to use STUN and sometimes TURN , right ?

My Server ist an UNRAID (V6.6.7 = latest) Server.
Everything runs in Dockers.
I access my Nextcloud through a nginx reverse Proxy (also Docker).
My nextcloud runs under nextcloud.[my domain].com (with ssl).
My nextcloud uses nginx.

So I tried to install coturn on the same Server that runs Nextcloud.
All guides I found dont use Docker but its easy to install coturn in a Docker.
I used the bprodoehl/turnserver Docker Image. Installation worked fine.

The coturn version the docker image uses is: 4.4.5.3-1.

My Docker configuration:

My coturn configuartion (/etc/turnserver.conf):
Screenshot_20190421_181142

Then I configured coturn like described in this Nextcloud Forum Post.
I dont use tls , because i dont want to install letsencrypt in the coturn docker (is no tls a problem ?).
Then i restarted the docker to enable the new config.
My coturn ist bypassing the reverse proxy.

After that i filled in the input fields in the talk settings like:
STUN: cloud.[mydomain].com:3478
TURN: cloud.[mydomain].com:3478
secret: test

(of course my real domain)(secret “test” just for testing :grinning:)
But then the test Server didnt work.
(i also tried with nextcloud.[my domain].com but nothing changed)
(i also tried port 5349)

In the JS Console i can see that the turn server doesnt find any candidates:

Of course i created a Port Forwarding and i can access cloud.[my domain].com:3478 in my browser (over public domain / not local ip):

But when I use this TURN test it seems to work:


(is it really working in the test ?)

I tried multiple other guides (everything i could find) but i couldnt get it working.
I tried to reinstall the Talk app but nothing changed.

Theres nothing about Talk in the nextcloud log.
My coturn log is following:


(should the “relay adress to use” be my global ip , because its not !?)

My Docker Log doesnt show any errors.

I am relly confused because cotrun seems to work and is reachable. The only thing thats not working ist enabling turn in nextcloud.

I am a beginner at turn but i have enough experience with networking / servers in general.

Should i try to use another docker image ?
Is my coturn config ok ?
Coturn does STUN and TURN , right?

Thanks in advance :wink:

#2

According to your coTURN version you need to add lt-cred-mech as well and at best no-loopback-peers.

You mean running the TURN server test within Nextcloud settings?

No in case of NAT it’s the local IP. Not sure if in case of docker with another proxy between something needs to be done different or not.

In case adding the above settings did not solve the TURN test from Nextcloud GUI fails, try to install it outside of docker.

1 Like
#3

Thanks for your fast reply.

I am pretty sure i have tried that but i will try again.

Ok.

No docker should not make a difference. Every docker runs on the same local and public ip. Every docker runs with a network bridge. Every docker can acces any exposed ports of every other docker via localhost or the local ip (and of course the public ip).

I dont want to install it outside of docker because its the whole point of unraid to do everything in dockers , so you can manage everything in the web interfaces. Unraid is like freenas but not free and with linux not FreeBSD.
I will probably try to install coturn on my raspberry Pi.

Thanks for your advice :slightly_smiling_face:

#4

Jes. Sorry

#5

That was the solution!
Thank you very much!

I am sure i have already tried that before but then something other had to be wrong.