I can see update 14 only in betachannel but not in stable one. NextcloudPI

So im running nextcloudpi on my raspberrypi 3 and im waiting for the 14 update. But still to this day its only in the beta update channel available. =(
I understood that nextcloud 14 already came officaly out so its in stable channel is it not? NextcloudPi uses the same update channel as any other nextcloud right?

1 Like

Thanks so i just need to wait some more! That I was suspecting. But “today”? I saw that anouncement a week ago. thats why i was wondering is the incremental update still not buy me :grin: inpatient

There are quite some issues reported on this forum. Maybe the devs are checking them before continue with the roll out…

@voldemort

that answers all possible questions.

and this as well… (bit as @T53N remarked as well: there seem to be some issues so far,

and last and MOST important hint:

nuff said

I switched to beta, did the update without problems, and activated stable again. All works well.

If you are using NCP, upgrade through ncp-web. There is a bug in NC that will make it complain about .user.ini

Nice forum ! I will share it to all of my friends.

ufabet : po

Having a similar experience here… Okay then it might just be that you haven’t rolled out the version to us.

One thing that is very confusing though and this should be fixed. If you do incremental rollouts… please sync the notification about a new version with the availability of the update mechanism (button). I am daily reminded by my local client and the web interface that there is an update waiting and when I go to the backend to do it… there is no Button!

PS: I am not using Docker… regular webinstaller

1 Like

please put into consideration that there were some issues found in nc14.0.0 and so it could have happened that devs stopped rolling out this version as well.

2 Likes

14.01just appeared yesterday in my inbox.

But still the notifications should be fixed and only appear if they are actionable.

Much appreciated

Yes i got it also yesterday. Now after updating I have a warning that

Missing index "share_with_index" in table "oc_share".
Missing index "parent_index" in table "oc_share".
Missing index "fs_mtime" in table "oc_filecache".

Is it lethal?

fix it with ncc db:add-missing-indices

I updated using the Nextcloud updater and had some errors. Tried

 ncc db:add-missing-indices

it fixed most of the issues but I still get an invalid file warning, here is the results of the invalid file:

Technical information
=====================
The following list covers which files have failed the integrity check. Please read
the previous linked documentation to learn more about the errors and how to fix
them.

Results
=======
- core
    - INVALID_HASH
        - .user.ini
- news
    - FILE_MISSING
        - vendor/ezyang/htmlpurifier/maintenance/.htaccess

Raw output
==========
Array
(
    [core] => Array
        (
            [INVALID_HASH] => Array
                (
                    [.user.ini] => Array
                        (
                            [expected] => REMOVED FOR REDDIT
                            [current] => REMOVED FOR REDDIT
                        )

                )

        )

    [news] => Array
        (
            [FILE_MISSING] => Array
                (
                    [vendor/ezyang/htmlpurifier/maintenance/.htaccess] => Array
                        (
                            [expected] => REMOVED FOR REDDIT
                            [current] => 
                        )

                )

        )

)

I also can’t upload anything to the server because it’s apparently locked in maintenance mode. Do I have to restore using my backup and then use the NCP-updater instead?

The option in the NCPI web panel:

 nc-autoupdate-nc 

was already enabled and did not update on it’s own apparently…so that’s another issue…

My server is set up on Debian using the curl bash command on ownyourbits.com site.

Did the

 ncc db:add-missing-indices

fix your problems? It fixed most of mine but I still have an “invalid file”

This has already been asked in this forums