I can no longer set the "Maximum upload size"

I did the update to version 16 today.
Unfortunately, I can no longer set the “Maximum upload size”.
The point is simply no longer available in the WebUi for me.

Manually setting the parameters in the “.user.ini


php_value upload_max_filesize 50M
php_value post_max_size 50M
in the “.htaccess

did not help either.

No errors in the log but also no upload-limit :flushed:

Has anyone noticed a similar behavior after the update to version 16?

Can it be solved?

what is the error you got? anything in nextcloud logs? i dont know if it will help and if its really related to my latest update (to 15.0.7 however) but right now I got a permission issue that prevents me from being able to edit this using the NC interface.

chmod(): Operation not permitted at /var/www/html/nextcloud/lib/private/Log/File.php#141

So I went to the php file in question and noticed the following:

130                 foreach($entry as $key => $value) {
131                         if(is_string($value)) {
132                                 $testEncode = json_encode($value);
133                                 if($testEncode === false) {
134                                         $entry[$key] = utf8_encode($value);
135                                 }
136                         }
137                 }
138                 $entry = json_encode($entry, JSON_PARTIAL_OUTPUT_ON_ERROR);
139                 $handle = @fopen($this->logFile, 'a');
140                 if ($this->logFileMode > 0 && (fileperms($this->logFile) & 0777) != $this->logFileMode) {
141                         @chmod($this->logFile, $this->logFileMode);
142                 }
143                 if ($handle) {
144                         fwrite($handle, $entry."\n");
145                         fclose($handle);
146                 } else {
147                         // Fall back to error_log
148                         error_log($entry);
149                 }
150                 if (php_sapi_name() === 'cli-server') {
151                         if (!\is_string($message)) {
152                                 $message = json_encode($message);
153                         }
154                         error_log($message, 4);
155                 }
156         }

Unfortunately, I’m not really good at coding. It’s even worst with php so I don’t really know what to do. Ill certainly follow your thread so I can get a better understanding of how this works.

There is no Error in the NC-logfile.

what have you entered in the ui ? 50 M ?

As I already wrote:
“The point is simply no longer available in the WebUi for me.”

Means the field no longer exists in the WebUI of my installation since the version update.
For security I have also set the theme to default. The problem persists.

But even the manual adjustments in the “.user.ini” and “.htaccess” file do not bring the expected effect. I set both values to “50M” but can upload a 100MB file. But I already wrote that in the opening article.

Can anyone explain why the “upload and memory setting” has been removed?

See it on git…

See here: https://github.com/nextcloud/server/pull/13990