I am unable to find expiring messages settings in android app (v17.20.0 Alpha 11) , but it is accessible in web app (2

hi, I have been using Next Cloud and Talk for some time, but there is a problem the settings for expiry messages option is available in the web-based app, but it is not available in my Android app


like in this image which I found from GitHub pull request, this expire chat message option is not visible to me

Well, in theory even though you’re running a strange alpha release it should be in there.

I will say it’s definitely in the current stable release - I’m looking at it. Can you post a screen shot of your Conversation Info from one of your conversations where you aren’t seeing the Message Expiration header/section ← those may be some hints too since the implementation adjusted the labels a bit from those original screenshots above from the looks of it

Your alpha release is outdated. The current stable release is 18.0.1

https://f-droid.org/packages/com.nextcloud.talk2/

https://play.google.com/store/apps/details?id=com.nextcloud.talk2

hi, @bb77 and @jtr , thanks for the reply but I tried to download the latest version from Google Play Store of Nextcloud Talk and the message expire chat option is not visible there, you can see this in my video as well

my web server app version is currently 26.0.9, is it because of this thing?

Most likely yes. As far as I remember, the feature was first introduced in version 17.x.x of the server app, which is only compatible with Nextcloud 27.

I was apparently mistaken in my previous post. I couldn’t find out exactly when it was introduced, but it must have been before Nexcloud 27, probably at least since Nexcloud 25.

I found this GitHub issue from January 2023 in which the feature was already a thing. However, at that time it only seemed to work for new conversations and not with existing ones. Maybe that’s still the case with the version in Nextcloud 26

Introduced in 25/15: Capabilities - Nextcloud Talk API documentation most of the time it helps to check the capabilities for new features :wink:

2 Likes

now I have updated my web app to 27.1.5 and Android talk to v17.1.3, and still by creating a new chat it is not visible on Android mobile but visible in the web app

Then I don’t know why that is. I’m on 27.1.5 / 17.1.3 17.1.4 as well, with the latest Android app, and the option is definitely there, even in older conversations. What I don’t know is whether it would actually work for older messages, as I’ve never tried it.

Wait… You seem to be mixing up the vesions of the different apps here.

The current versions are as follows:

  • Latest Nextcloud 27 server version: 27.1.5
  • Latest Nextcloud Talk server app (spreed) for NC 27: 17.1.4
  • Latest Android app: 18.0.1

I appreciate your help, I can try but I am unable to find the APK of v17.1.4, I can only get of v17.1.3, can you please share the APK download link with me (of 17.1.4), currently this is my screenshot,

my Nextcloud server version is 27.1.5

You can download the APK of 18.0.1 from the F-Droid link I posted here: I am unable to find expiring messages settings in android app (v17.20.0 Alpha 11) , but it is accessible in web app (2 - #3 by bb77

The same link is also on the official page for the app in the Nextcloud App Store: Nextcloud Talk for Android - Apps - App Store - Nextcloud

I have tried with the latest version 18.0.1, which is also available on Google Play Store as well, I was trying to download 17.1.4 as you said that it is the most stable with Nextcloud 27,
the F-droid has only 17.1.3 and 18.0.1, and both are not working for me, don’t know why. :frowning:

image

Yes, I admit I have contributed my part to the confusion :wink:

But let’s forget everything that was said in this thread, and I’ll summarise again (I double-checked everything)

With the following combination of Nextcloud Server, Nextcloud Server app and Android app the option is defeintely available for me in the Android app:

  • Nextcloud server version: 27.1.5
  • Talk server app (spreed): 17.1.4
  • Android app: 18.0.1

If it’s not available for you when using the same versions, the problem must be somewhere else. Unfortunately I don’t know where…

by following all these three versions, I am still unable to get that option but thanks again for your help

can you please do me a last favor by sending the screenshot of the option that is being shown to you, that would be a help

I can only assume that this is your issue:

But it should not be visible on web in this case as well…

Created a bug at Message expiration is not hidden when using ajax for background jobs · Issue #11335 · nextcloud/spreed · GitHub for web.

It looks exactley like on the screen shots you posted in your opening post, except that mine is in German: