Hv-kvp-daemon - waiting time on boot on a fresh installation (vmware)

Downloaded the 500GB VM from @enoch85.
While booting on VMWare, I get the error
A start job is running for /sys/devices/virtual/misc/vmbus!hv_kvp

There are several ways to get rid of the 1m30s wait time each boot
(i.e. “systemctl disable hv-kvp-daemon.service”).
Do I have to do that only after the install script is done?
Is this the correct way to disable the Hyper-V driver anyway?

I’d say that’s the correct way of doing it.

This is a bug in Ubuntu 20.04 and I’ve been waiting for the to release a fix, but it seems it’s still not working… Maybe it’s time for a workaround…

Thanks for pointing this out, I will put it on my TODO.

It’s fixed with this PR.

Will be released in the next version.