Hub II 23.0 ftp scan and sync


Sorry, if this topic is already exists, I couldn’t find any similar.
I use the latest Server (23.0.2) on linux (centos 7.9, php 8.0.15, Mariadb 10.3) and latest Mac OS client (3.4.2). I have an ftp as external storage and Nextcloud cannot detect change on the ftp. So I run a script every day to scan files:
sudo -u apache php /var/www/html/nextcloud/occ files:scan --path=…

I can live with that, no problem, but. Sincs 23.0 it always sync the whole ftp external storage on my Mac client. 20-30G every day for hours, but the change is usually only 0,5-1G data.

Can you help me, what changed? Is the problem at my side or with Nextcloud 23?
It worked with 22, but not with 23.0.0. and 23.0.2


The sync is done by the desktop client, or?
Which version are you using?

Mac OS client (3.4.2)

Hi rakekniven,

Can you help?

Never worked with ftp storage :thinking:

I just can point you to the client log file to check what is going wrong.

I created a client logfile but I cannot find any error in it. Seems like normal, for exmaple for this file it finds the checksum, mtime is the same, still syncing

2022-02-24 08:04:35:686 [ info sync.discovery /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-9042/src/libsync/discovery.cpp:362 ]:      Processing "Reolink/erkely/2022/02/15/Erkely_0
1_20220215075235.mp4" | valid: true/true/true | mtime: 1644911248/1644911248/1644911248 | size: 12450445/12450445/12450445 | etag: "62172d4612005"//"62172d4612005" | checksum: "SHA1:e03985c8
ebbb74c6b1b92c6c76f185cc41377ed2"//"" | perm: "WDNVm"//"WDNVm" | fileid: "00467316oc5huu05n667"//"00467316oc5huu05n667" | inode: 177691425/177691425/ | type: CSyncEnums::ItemTypeFile/CSyncEn
ums::ItemTypeFile/CSyncEnums::ItemTypeFile | e2ee: false/false | e2eeMangledName: ""/""
2022-02-24 08:04:35:687 [ info sync.discovery /var/folders/yr/9dx0mtfj7kdf4725tmcz6md80000gp/T/macos-9042/src/libsync/discovery.cpp:1367 ]:     Discovered "Reolink/erkely/2022/02/15/Erkely_01_20220215075235.mp4" CSyncEnums::CSYNC_INSTRUCTION_NONE OCC::SyncFileItem::None CSyncEnums::ItemTypeFile

Sorry. I do not use ftp but Local. But i never used occ files:scan with your parameter –path outside user dirs. Perhaps here is the error.

Can you “unmount” your ftp and re-run occ files-scan --all? Mount ftp again without scan and test sync to your client.

–all will rescan everything local and ftp as well and I don’t need that. That will be a lot of time. Under the --path there is only the ftp external storage.

I have used this daily ftp rescan WA since NC 19 I think, maybe later.

Yes my fault. If you have got only a few users, you can scan only the users. But I am afraid that the old entries from the FTP directory are not forgotten.

Read File access control. Maybe you can deny sync for special folders to clients.

1 Like