HTTPS setup, getting "command not found"

I’m trying to get https setup. When running ‘$ sudo nextcloud.enable-https lets-encrypt’ I get the error “sudo: nextcloud.enable: command not found”. Seems like a linux issue but I’m too inexperienced to make sense of it. This is a Linode provided install running on Debian.

Hi @jonkmacj

This command is meant to be used with the Nextcloud Snap package. I don’t think that Linode uses the Snap package for their Marketplace Apps. As I understand it from a quick look at their instructions, they use a scripted installation based on a LAMP stack. There should be an option for Let’s encrypt when you setup your Nextcloud instance. For this to work a domain name and a DNS record pointing to your Linode instance is necessary.

From their instructions:

Would you like to use a free Let’s Encrypt SSL certificate? (Requires domain) Enable a free HTTPS CertBot SSL certificate on the Nextcloud domain. If you do not provide a value, no is set by default.

In theory, this should still be possible afterwards by installing certbot on your instance. The prerequisites for this are, as mentioned, a domain name and a corresponding DNS A record.

1 Like

This is great and exactly the kind of direction I was hoping for. Thank you bb77!