HTTPS required error


I have a huge problem with the Passwords app since yesterday.
Everything was working just fine, and no update and nothing and since yesterday I cannot access the Passwords app inside Nextcloud via web or from Android App because it says HTTPS REQUIRED even though I run my Nextcloud server through Https and the page is loaded through HTTPS. On the HTTPS Status Report I don’t see anything abnormal besides the fact that Nextcloud Reported Protocol says http and expected is https. On the client side everything is okay and I haven’t changed anything … So where is my mistake? What can I link here to help you diagnose my problem? Thank you

Because of your infos HTTP vs. HTTPS you use perhaps a reverse proxy.

Please post more details e.g.:

  • nginx vs. apache2 (including configuration)
  • infos about http and https
  • config/config.php of your nextcloud
  • linux system (version), nextcloud (version), …
  • logs, screenshots, …
  • errors in browser (e.g. Firefox → F12 → Network analysis)

Well I’m using it as NextCloudPi so it’s a Rapsberry Pi 3b.
It’s running Apache2, NextCloud 21.0.4 with standard configuration, basically I did not changed anything to the default configuration. Which configuration files should I post here?


I am seeing the same issue since the latest nextcloudpi update on my machine.

NextCloudPi version	v1.39.16
NextCloudPi image	NextCloudPi_11-27-20
distribution	Armbian 21.02.0-trunk Buster \l

When checking the nextcloudpi version release I am on, it could be that this somehow has affected our setup:

If you navigate to https://nextcloudpi.local:4443/?app=nc-httpsonly
and you untick https only, passwords should work again.

At least it does for me.

1 Like

It does work. Thank you … But isn’t this kinda un-safe?

Can confirm latest stable update breaks passwords app as described.

Is there a beta branch we can update to where the issue is fixed?

I don’t think the https being off means you’re turning off https.

In short, I think it’s possibly a user interface bug, if you look at the commit I linked it’s a reverse of a condition, and I think that’s either a ui bug or a logic problem.

openssl s_client -connect <yourdomainname>:443 -showcerts should show you your certificates.
Try navigating to http://yourdomainname, you should get redirected to https://yourdomainname.

My certs are valid, the redirect to https happen, all despite this option being off.

I don’t know why it’s broken and no there is no “beta” branch that I can see, but feel free to open an issue with all the details on github: Issues · nextcloud/nextcloudpi · GitHub

Or even better try and find a fix after opening said issue :smile:


Because of your screenshot:
Can you post this values in config/config.php:

'overwrite.cli.url' => '',
'overwriteprotocol' => 'https',

If in the second line is set http please test it with https

I didn’t have those two values in my config file at all. Switched back https only and copied the two values and now it works like a charm. Thank you

1 Like