Https enabled and now cant connect


Can someone help me get https working please.

I have a snap install of nextcloud on ubuntuserver 16.04 that was working correclty in internal network for last few months

I tried to enable ssl certificates using certbot which had apache errors of httpd not running.

eventually i ran the command sudo nextcloud.enable-https lets-encrypt

Which seemed to work correctly but now when i try to login via local IP it is forced https and cannot connect.

Additionally i now cant connect through my ddns address, which is correctly pointing and ports opened on firewall as i was able to connect through this before running this command.

Did i miss anything?

Many thanks, Dave

Ok i finally got lets encrypt to install a certificate.

But i still cant connect to nextcloud externally or internally. how do I get nextcloud using the certificates

You have to let Apache know where the CertificateFile and CertificateKey are and reload Apache.
Edit /etc/apache2/sites-enabled/nextcloud.conf to include:

     SSLEngine on
 	SSLCertificateFile	/etc/letsencrypt/live/my.domain.tld/fullchain.pem
 	SSLCertificateKeyFile	/etc/letsencrypt/keys/0000_key-certbot.pem

Edit: should report issues snap/https here

1 Like

Check this out: Apache 2.4.18 + Letsencrypt + Ubuntu 16.04 - SSL config for A+