HTTP/2, problem with enabling


I want to enable HTTP/2 for Nextcloud, but it doesn’t seem to work.

Basic info:

  • Debian 8,

  • Apache/2.4.29,

What is my problem?

I’d like to enable HTTP/2 for my Nextcloud drive, but when I add it to my VirtualHost file, it still doesn’t load via HTTP/2.

What did I do to enable it?

I run my server on Debian 8, so if I wanted to have HTTP/2 enabled, I had to download Apache from testing repository, because HTTP/2 isn’t in stable repository.

After this I enabled http2 module using a command: “a2enmod http2”. It worked perfectly. All of the configuration files for http2 are in place (/etc/apache2/mods-available).

At the end I added: "Protocols h2 http/1.1" to my VirtualHost file which points to Nextcloud.

This in my VirtualHost file:

What is the problem?

When I access Nextcloud or Ampache (alongside Nextcloud), it still doesn’t load via HTTP/2, I also tested it with this website: “” and it shows me a negative result.

What is wrong, anyone knows? Can anyone help me with that? I would be extremely glad if someone did.

Make sure you have your http2 module loaded

LoadModule http2_module modules/

Where do I check for this?

I am pretty sure you can add that statement in your config

I checked for it, and yes, it seems to be enabled. I checked it in /etc/apache2/mods-available/http2.load file. Nextcloud still loads via HTTP/1.1, what can I do to change it?