HPB down after ncp-dist-upgrade to Debian 12

I have an intel nuc with an x86_64 cpu (I can provide full lspci output later), that was running nextcloudpi on Debian 11.

I updated to the latest ncp version (1.54.2), then ran sudo apt update and sudo apt upgrade. PHP updated to 8.1 and I got an alert that it wasn’t installed because I’m using apache2 and it doesn’t support that php version.

Afterwards, I ran sudo ncp-dist-upgrade and it ran all night. This morning, I rebooted and HPB service is down.

Here is my log from the debian 11 to 12 upgrade: https://pastebin.com/wjtSUeDf

I am guessing it has to do with the php package upgrade and if I revert that somehow that would fix it. How could I remove that php package and install the latest supported php package that NCP/apache2 requires? (and what version would that be?)

EDIT:
machine specs: Debian GNU/Linux 12 \n \luptime is 20:41:30 up 14:31, 0 user, load aver - Pastebin.com

package upgrade output from before upgrade to debian 12: Reading package lists... DoneBuilding dependency tree... DoneReading state i - Pastebin.com

ncp-report output: <details><summary>NextcloudPi diagnostics</summary>```grep: /etc/apach - Pastebin.com

not sure what fixed it but I did the steps outlined on top here https://github.com/nextcloud/nextcloudpi/issues/1913 per the @theCalcaholic

I don’t think any of the steps really did anything until the last step/step 4. This took it out of maintenance mode. But I can’t say for sure what fixed it out of those 4 steps