Howto: Install Nextcloud Desktop/Client on Raspberry Pi Os (bullseye)

In the Raspberry Pi Os there is a package ‘nextcloud-desktop’ included but unfortunatley it doesn’t work. Also several Tutorials on compling didn’t work for me, but fortunatley it is in the debian repository (also arm architecture). Simple said: we add the debian repository to the Raspberry Pi Os and install it from there.

Quick & Dirty: (Will create signature warnings)
Add following line (as root) to the file: /etc/apt/sorces.list: deb [allow-insecure=yes] http://deb.debian.org/debian bullseye main
In command line: sudo apt update
In command line: sudo apt install -y nextcloud-desktop

More appropriate with key from Debian:
Download Archive signing Key from: ftp-master.debian.org Archive Signing Keys
(Currently: https://ftp-master.debian.org/keys/archive-key-11.asc)
In comand line navigate to the folder where the downloaded file is located and execute: sudo apt-key add (example: sudo apt-key add archive-key-11.asc)

Then Create a new file (e.g. debian.list) in folder (as root): /etc/apt/sources.list.d/
Add following line in your newly created file (e.g. /etc/apt/sources.list.d/debian.list): deb http://ftp.debian.org/debian stable main contrib non-free
In command line: sudo apt update
In command line: sudo apt install -y nextcloud-desktop

I hope it helps somebody else.

Best Regards

1 Like

the debian package sources for nextcloud are not very well.
Just add the official package source and the public key of the nextcloud client to your system update the package sources and install the package.

in case it helps anyone else, i followed this guide to set mine up a couple of weeks ago on a headless Pi4B running bullsye

https://www.learnlinux.tv/nextcloud-complete-setup-guide/
same guy did a youtube to easily follow

what is the official package source? please elaborate

I just googled for an easy blog to follow along and i found this:
https://linuxconfig.org/how-to-install-nextcloud-client-on-ubuntu-18-04-bionic-beaver-linux
This instructions are for Ubuntu but Ubuntu is based on debian and becaus they use the same packagemanager apt you can just follow the instructions in the link above.

Since this is not ubuntu I tried it that way: https://linuxconfig.org/how-to-install-the-nextcloud-client-on-debian-and-ubuntu

But didn’t work for me, couldn’t resolve some package dependencie problems

Hi @birdynm

That’s why you shouldn’t use PPAs on Debian. PPAs are only be meant to be used on Ubuntu, and even there, they have to support the specific version of Ubuntu you are using them. Maybe the Flatpak or the Snap package is an option for you… They are self contained containers that come with all the required dependencies already…

Flatpak:

Install Flatpak and the Flathub Repository:
https://flatpak.org/setup/Raspberry%20Pi%20OS/

Install the Nextcloud Desktop Client:
https://flathub.org/apps/details/com.nextcloud.desktopclient.nextcloud

Snap:

https://snapcraft.io/install/nextcloud-desktop-client/raspbian

Thank you so much! I have been trying to install the Nextcloud Client on a Raspberry 3 B+ using Debian Bullseye for hours, and this finally worked! Summarized for easier copy & pasting:
Run:

sudo nano /etc/apt/sources.list

then append this line, then save (Ctrl + X, Y, Enter):

deb [allow-insecure=yes] http://deb.debian.org/debian bullseye main

Then run:

sudo apt update
sudo apt install nextcloud-desktop

You need to confirm installation and unauthenticated installation with “y” twice.
If this worked, run Nextcloud with:

nextcloud

Hi @birdynm

Thanks a lot for your post.

When i insert the key from Debian and fill in the file debian.list as described by you i got an error message from the build in update facility of RASPOS64 (someting like release notes missing).

Using the following line in debian.list worked fine for me:

deb http ://ftp.ca.debian.org/debian stretch stable main contrib non-free

I guess replacing stretch by bullseye will also work (not yet tried; will come back when it’s NOT working :slight_smile: ).

PS. Remove the space after http. Was needed to avoid an autocorrect.