HowTo: Install Collabora Online on Ubuntu 16.04. (without Docker!)



Could you explain

–with-max-connections=XX / --with-max-documents=XX

further? Could you explain the whole the ./configure … command you used?

Kind regards, go4ncloud.


./configure --enable-silent-rules --with-lokit-path=/opt/online/bundled/include --with-lo-path=/opt/libreoffice/instdir --with-poco-includes=/usr/local/include --with-poco-libs=/usr/local/lib --with-max-connections=50 --with-max-documents=20 --enable-debug

This is my command but @husisusi when i compile with lool i have gcc errors of compilation, and when i compile with root loolwsd start on local port 9981 and can’t be telnet from a computer in the same network.

I think i will restart from zero to see what’s going on


I can just tell you , if you have new Ubuntu or Debian instalation and you run my script, the installation will be successfull. I dont understand why are you changing tha configuration, you can do everything in the script. Please do not complicate


I made this from a start new ubuntu server 16.04.1
I need to add --with-max-connections and --with-max-documents because with the starter only 10 docs or 20 connections is too low for my use.


You will find maxdoc and maxcon in the script. Please Download the last version.


Great. i will tell you in 7hours… :slight_smile:


It’s working ! port 9980, accessible from other computers on network.
Tonight i will make some test.
Thank you


FYI: Yes, it works, with no Limit.


I have exactly the same message about comparison between signed and unsigned integer expression while compiling loolwsd, so can You explain how You fixed that?


I don’t know exactly the origin of problem. But I delete everything in /opt and I followed husisusi instructions and everything went well


Solved problem with owncloud. I imported certificate in this way:
sudo -u www-data php occ security:certificates:import /etc/loolwsd/cert.pem


more dependencies to mention of my debian installation


These were missing; now Libreoffice make will start.


That is great really looking forward to further compiles especially for Arm.

32 & 64 bit Arm would be fantastic.

This is all great news and we will see how long the self compile route remains open and possible.
Also if anyone could change the limitations to 30 documents & 15 connections, so that a small workgroup can open a couple of documents at the same time would be great.

40/20 would be perfect as all I am aiming at is small workgroups with a bit of headroom on multiple open documents and possible outside connections.
The 10/20 I can envisage being extremely restrictive and likely to hit limits with extremely small groups and struggle to understand why such a low level was initially chosen.

Would be great if one of you guys could maybe use virtual box to create an arm version and then dump the image even if you use CloneZilla as to be honest its quite an easy way to grab images, but anyway you wish as there would be a lot of Raspbians very happy.


It’s not a case for me, unfortunely: I’m on Arch Linux, so I can’t use that script.
At other hand, it starts look for me as dependencies problem. But first, can You acknowlege You doesn’t reinstall Your VM, but only cleared up /opt catalogue?


Yes, I cleared up /opt only.
Usually I work with Ubuntu or Debian, than I’m not Arch Linux specialist, but message that you got is only a warning. Then you can try to skip warning check with -k option (make -k). Don’t forget “make clean” before start a new build process.



My systems (Ubuntu 16.04, Debian 8.7) use DASH instead BASH. Now I’m interested to know if that causes compile failure of LibreOffice core. Could somebody tell me if he succeeded in compiling LibreOffice core using DASH.

Kind regards.



please Update the Corepath in Step one.

New one is:

The other one isnt working anymore.



Does this procedure work with a raspberrypi3 (as it is impossible to use docker install)?



@go4ncloud I have the understanding that DASH is a fast but incomplete shell interpreter, so it gives you speed on execution but it won’t have all the features that BASH has.

So i would recommend to always use BASH instead of DASH for the sake of your time while building applications.

Something like:
$ sudo bash or # bash
would do it.


Hab den ersten Eintrag entsprechend angepasst.
Danke an @husisusi (thx to you) für das gute Script.


i must say the lack of documentation of the limitation is nasty, they’d have been a lot wiser to have that upfront rather than finding that out in a nasty surprise. Thanks for the script, got it running in a VM with little issue. Libreoffice-online still feels a little buggy, and i’ve had my fair share of “javascript disabled” issues