HowTo: Install Collabora Online on Ubuntu 16.04. (without Docker!)


#102

Nice script. I got a fresh installed ubuntu 16.04.
I failed while starting the service (make run) with following error:

Launch this in your browser:

https://localhost:9980/loleaflet/f81ab32/loleaflet.html?file_path=file:///opt/online/test/data/hello-world.odt

Or for the Admin Console:

https://admin:admin@localhost:9980/loleaflet/dist/admin/admin.html

-24882 10:19:20.687860 [ docbrk_ws_24878 ] WRN SocketProcessor [docbrk_ws_24878]: Socket error.| common/IoUtil.cpp:78
-24882 10:19:20.687926 [ docbrk_ws_24878 ] INF SocketProcessor [docbrk_ws_24878] finished. stop: false, n: -1, payload size: 0, flags: 0| common/IoUtil.cpp:cb
Makefile:1956: recipe for target ‘run’ failed
make: *** [run] Error 70


#103

let me know your output:
lsof -i :9980
systemctl status loolwsd.service

try first to stop it:
systemctl stop loolwsd.service
Then as root:
su lool
cd /opt/online
make run


#104

Meanwhile the service is running and I configured the apache2

I have access to https://localhost/loleaflet/f81ab32/loleaflet.html?file_path=file:///opt/online/test/data/hello-world.odt
But in ownCloud/nextcloud there is this error:

Service is unavailable. Please try again later and report to your administrator if the issue persists.

Well, this is embarrassing, we cannot connect to your document. Please try again.

The logs:
OPI host is not on the same host as the WOPI client
No acceptable WOPI hosts found matching the target host [cc.cc.cc] in config.

I tryed to configure the loolwsd.xml.in and added the hosts, but it fails. :frowning:


#105

Hello Pisoko,

its loolwsd.xml and not loolwsd.xml.ini.


#106

Yeah, you’re right.
I edited the .xml and it works for me.

Is there any way to update this installation in the future without building a new server from the scratch? :smiley:


#107

Thank @husisusi! Your script works with debian 8.7, too!


#108

I’m glad to hear that. Is sudo in Debian 8.7 preinstalled or you have to install it?


#109

Seems to compile, here too. But the service script seems to be different. Did you change anything in some configuration? Make run doesn’t start either. I presume I have to change the loolwsd.xml first?


#110

Try to restart your Machine and use systemctl.


#111

My error - libkrb5-dev wasn’t installed, libreoffice compile failed. Now I manually go through the script and am optimistic it will work on debian one of these days.
Thank you - I will post news if there are any.


#112

Thank you for those information. I made some script updates and just test it on Debian.
If it works I will push the changes to git.


#113

I installed sudo by apt-get.
If I access from
https://192.168.10.70:9980/loleaflet/f9d54cd/loleaflet.html?file_path=file:///opt/online/test/data/hello-world.odt
it works.
But If I access from nextcloud I got “Access forbidden” message.
What I have to change in loolwsd.xml?


#114

Hi @joergschulz, make run works with defaut loolwsd.xml. Make sure to launch “make run” with lool user
su lool
cd /opt/online
make run


#115

Normally when opening a libreoffice file with nextcloud you have two options :

  • your loolwsd instance is called by a proxy and your proxy conf must have the SSL certs inside

  • your loolwsd instance is called directly by ports https://mynextcloud.test.com:9980 and you must have correct SSL certs inside loolwsd.xml

it seems that making work nextcloud/lool with self sign certificate is quite difficult


#116

Hi @Nemskiller thank for your help. In fact I think problem is self signed certificates. There is any way to configure loolwsd (by loolwsd.xml or other) to skip self signed certificates check?


#117

It is strange, i am using Owncloud 9 with self signed certificates and it works.
Try to use HAProx!


#118

OK! I added Support for Debian 8.7 and I fixed Debian systemd start for loolwsd.servic.
Can someone test it please?


#119

Hello @husisusi , i successfully pass your script.
How ever this is what i get when i want to : service loolwsd start / service loolwsd status

● loolwsd.service - LibreOffice On-Line WebSocket Daemon
Loaded: loaded (/lib/systemd/system/loolwsd.service; enabled; vendor preset: enabled)
Active: inactive (dead) (Result: exit-code) since Tue 2017-02-14 10:15:31 CET; 5min ago
Process: 18356 ExecStart=/opt/online/loolwsd --version --o:sys_template_path=/opt/online/systemplate --o:lo_template_path=/opt/libreoffice/instdir --o:child_root_path=/opt/onli
Main PID: 18356 (code=exited, status=203/EXEC)

Feb 14 10:15:31 office systemd[1]: loolwsd.service: Service hold-off time over, scheduling restart.
Feb 14 10:15:31 office systemd[1]: Stopped LibreOffice On-Line WebSocket Daemon.
Feb 14 10:15:31 office systemd[1]: loolwsd.service: Start request repeated too quickly.
Feb 14 10:15:31 office systemd[1]: Failed to start LibreOffice On-Line WebSocket Daemon.

It is normal that i don’t have this file loolwsd.xml in /etc/loolwsd/ ?
Or can i put one i had before to change some settings.

Thank for all the job you’ve made

EDIT :
When i look in /opt/online i don’t have a loolwsd file


#120

Hi Nemskiller,
Yes, if you use my script (Without to kill it by running), it is in /opt/online/loolwsd.xml.
If you don’t have it, something went wrong. Delete /opt/online : rm /opt/online -rf
Get the last script and delete some lines (from line 27 to line 85). And let the script install Onlineoffie again.


#122

@go4ncloud @husisusi

My fault was because of the post of @go4ncloud : post

in ./configure --help of Online there is :

–max-connections Set the limit on the total number of client
connections. Def: 20, Min: 3.
–max-documents Set the limit on the total number of documents. Def:
10, Min: 2.

So when i write in ./configure (…) --max-connections=20 (…) for exemple i got this :

configure: error: unrecognized option: --max-connections=20' Try./configure --help’ for more information

I tried : --max-connections 20
–max-connections=“20”

Nothing worked

EDIT ;

My fault… i didn’t know how to really use ./configure

this works : --with-max-connections=XX / --with-max-documents=XX