HowTo: Install Collabora Online on Ubuntu 16.04. (without Docker!)


#62

As the latest tag is not defined (which is the default tag), you may get an error like this:

docker: Error response from daemon: manifest for libreoffice/online:latest not found
To avoid that problem, use full reference (with an existing tag) like this: openoffice/online:master

docker pull libreoffice/online:master


#63

Alright. I can’t make working the libreoffice docker but, i use my own how to (code without docker) and it works !

But with little faillures :

  • i have some pictures/files missing
  • it can be related but i have a lot of errors in log and the file take some times to open.

I’m so busy, i’m gonna take some holidays and get back to get news later.

The big difference between code and lool it s the folder /opt/collaboraoffice5.1/ - /opt/libreoffice/


BAD NEWS : Even the LibreOffice Online have the limitation of 10 Docs openned and 20 Connections max. :cry:


#64

Thats batshit crazy, Libre limit LOOL to 10 Docs and 20 connections, like the 20 connections just sort of puts a perspective on this.
Why the feck would you want a connection to a document platform if you don’t have a document open!!!
Sightseeing! Dayout! Or maybe your just a fan of making TCP connections!


#65

Even with the new upgrade?
For the docker to work you have to manually copy your certs within the docker and edit the loolwds.html file

By the way it looks that after the update to Libreoffice5.1.3 I can now successfully build my image. it took almost 6 hours, but i was able to compile it in Debian Jessy and Ubuntu 16.04 on my two VMs, now am going to try the rest of the configurations. I’ll update once is done.


#66

@Nemskiller tested and trust his findings, its there prerogative but just seems at odds with The Document Foundation stated goals.

Ignore my hyperbole, just frustation as has been an advocate of LOOL for a long time now, its taken far to long and just see this as further hurdles to adoption.

Nextcloud needs the document app back in 11 as for some the ability to edit documents lan side means the restriction of 10 documents far outweighs the advantages of LOOL.

The documents app and lool need to be offered as parallel apps or the use of Nextcloud effectively hits the same restrictions.


#67

This would be great. So, you compiled LO 5.1.3. after pulling from github just like the OP documented? Or did you have to tweak something (like firebird)?


#68

Do you think the 10 doc, 20 connection restriction might have been put in place to temporarily keep a server from crashing with many people using it in the development process? Maybe they forgot to remove or mention how to change it when released? Maybe that setting is simply in a configuration file not yet documented that simply needs changed?

It makes sense to have settings like that to keep a production server from getting out of control. Maybe they set it low to test those settings, and forgot about telling people how to increase the limits.


#69

I don’t really think so. In the market there is as for right now 2 main options for office documents.

  • Microsoft Office 365
  • Google Apps

And they both have a price, i think that CODE is a way to spread the news about a new market competitor.

  • Collabora Online

Let users play with it, if you may call it that way, so they can compete with the other 2 private cloud solutions, reaching potential clients that already have started taking over their cloud infrastructure.

Later in time, who knows when, it may become free of charge, as in free beer, but i don’t see it as a near future.
So right now, i would suggest to stick with your copy of LibreOffice 5 and keep from there, that at the end is what you are using on CODE.

So, did CODE get us all excited, yes, is it a production product, no.

My thought about it is that, i didn’t think they will just hand over a project that has been developed for around 5 years with no direct sponsorship from the public.

I run a business myself and i understand where they are coming from, but i don’t prise the lack of information in the first place.


#70

I completely agree and its Collabora’s prerogative, but actually its untrue about public support unless you are talking about the 30% of the code that Collabora have contributed. 30% of what you say is true.

Irrespective of that in Nextcloud 11 it does put Nextcloud in an extremely funny position, of not having a document viewer that can even scale into a modest workgroup, unless you stick with PDF.


#71

Some people bring the bread some other the milk to the table.


#72

@Ark74 Sure, but I’m not going to assume. Did they document, or announce anything that says they are trying to impose limitations? If you find something that announces the limitation, then I will believe you. I plan on compiling a copy myself in a couple days, and if a limitation isn’t announced by then; I’ll just look for a setting.


#73

Its hardcoded and proved by many in the forum already, you can try compiling the code, but it doesn’t work, as proved by many in the forum already.
The release is neither opensource or unrestricted and the only working form is a docker binary with restrictions.

The fact you can not find details of this restriction is actually worse and casts doubt on the whole honesty and offering of Collabora Code. It is not what it says on the tin.
It comes up with a big message when you try more than 10 documents, there are no settings as the admin console is not part of code.

https://pydio.com/forum/f/topic/collabora-limitation-how-ues-it/


#74

I can confirm that it works.
Many do not differ between Collabora and Onlineoffice.
I am fed up with the … (not yet documented)…
I am working on install-script that will do all the work on Ubuntu 16.04.
I believe it will be ready to use in 2-3 days.



HowTo: Install Onlineoffice on Ubuntu/Debian (No Docker No Limitation)
#75

Thank you for explaining, and posting the link. I understand the limitations much better.


#76

We know it works, its been tried, its the same as Collabora Code and has a 10 document limit that for some reason is not documented.

I am taking @Nemskiller at face value here but see no reason why *HowTo:* Install Collabora Online on Ubuntu 16.04. (without Docker!) this is not absolutely true.

If we can get a few more just to test and open more than 10 documents with the Libre version, then please post results.


#77

@husisusi, an install-script will be great! Another question: I have some problems with Letsencrypt certificates because I want deploy Nexcloud + Collabora in private lan and Letsencrypt need a public domain. Someone know a solution with openssl selfsigned certificates?


#78

There are a few howtos out there, just google for them :wink:


#79

Lets encrypt will allow you just to get the certs if you don’t have a public lan.


There are two pages there standalone & manual

Collabora is installed with docker run -t -d -p 127.0.0.1:9980:9980 -e 'domain=cloud\\.nextcloud\\.com' --restart always --cap-add MKNOD collabora/code
or
docker run -t -d -p 127.0.0.1:9980:9980 -e "domain=<your-dot-escaped-domain>" --cap-add MKNOD libreoffice/online:master

You don’t actually need the first docker pull collabora/code

If you mean by install script set up the Apache reverse proxy or maybe a complete Nextcloud install that would be cool, there are snap installs and docker containers already though.
Because of the distro variances in the support of Aufs its prob better to swap to device-mapper in the script so it can be cross distro. The performance hit of using device-mapper and a loop-back isn’t going to be a problem for a 10 document restricted docker container.


#80

for the self-compiled version (and probably the docker version as well) it is necessary to tweak the access settings as the OFFICE user will by standard not be able to access the letsencrypt files. I resolved this one by creating copies and changing access privileges for these copies.


#81

I really in hype for this script.
Because i tryied again to build LooL from the last sources and i have a lot of fails …

Building WSD :

libtoolize (no prob)
aclocal give me : aclocal: error: ‘configure.ac’ is required
So i took the configure.ac in the root folder and copy it in wsd.
then aclocal give me : warning: couldn’t open directory ‘m4’: No such file or directory