How to use Antivirus app(clamav)

I’m installed antivius app from app store.
First, in the case of mode is Executable,
I have been pointed out that there is no /usr/bin/clamscan when I look at the log. But actually there is clamscan there. I can also run clamscan. Do I need to adjust the path in Nextcloud?

Error no app in context RuntimeException: The antivirus executable could not be found at /usr/bin/clamscan

In the case of Daemon (socket),
It seems there is no permission of sock. Clamav’s conf file specifies “User root” and “DatabaseOwner root”. I can not start unless clamd@scan is root. Nextcloud is not the root user. In this case, how should it be set?
I think that this is general knowledge rather than Nextcloud, please let me know.

RuntimeException: Cannot connect to “/var/run/clamd.scan/clamd.sock”: Permission denied (code 13)

Let Nextcloud users be NC-USER.
I executed “/var/run/clamd.scan/” against “chown -R NC-USER:root”.
The error was continued when I changed it, but it seems that the error ceased to appear after a while. Is this method correct?

https://docs.nextcloud.com/server/13/admin_manual/configuration_server/antivirus_configuration.html

1 Like

Excuse me, I am seeing it. I have set up ClamAV itself. ClamAV is working normally unless through Nextcloud. Perhaps I can use Daemon(socket). But the question is Executable mode.
The official manual does not specify what to specify in addition to “/usr/bin/clamscan”. In SSH, I can be executed with clamscan only, or I can be executed with /usr/bin/clamscan. For example, changing to “clamscan” only in the path column to clasmscan can not be executed in Nextcloud as well. Is there any other way to specify ‘clamscan’ in Nextcloud settings?

The Executable option requires the path to clamscan , which is the interactive ClamAV scanning command. Nextcloud should find it automatically.

Nextcloud will automatically search for “it”. Is that about a path? Or is it a virus inspection subject?

2 Likes

@zoo3 did you ever figure this out? I have the same issue.

This issue is unresolved because I gave up using ClamAV.

1 Like

Did you replace it with anything or just gave up on virus scanning totally?

1 Like

The solution is to use it with a tcp socket.

Scroll down this page and follow [aaronhuggins]'s reply.

I hope that I made your day!