How to share a collective with a group?

Maybe I did not understand the way it is supposed to work - but this does not work:

  1. Create a collective
  2. Select the members for this collective
  3. Add a user group (which contains about 30 users) to the circle

Result: the users in the group do not see the collective.

The only thing which works is to add all users from the group individually. However - since the Nextcloud instance has about 180 users and about 20 groups managing access to collectives this way is not really useful.

Is this the intended behaviour that user groups as circle members don’t work? Or this a bug?

Also the whole way how a collective is shared seems to be a bit odd:

Instead of adding users, groups and circles there is only an automatically created circle which is named after the collective. This also means when you rename the circle also the collective gets renamed. It would be much more logical to have list of users, groups and circles which are allowed to access the collective.

Dear @awelzel. The scenario you described should work: adding users to a group that is part of a collective should make the collective available to these users immediately. I use this setup myself and it works well.

Could it be that you face this issue on an instance that got installed before Nextcloud 22? In this case, it might be that the migration of circles to Nextcloud 22 didn’t run successfully. I faced this in the past. Running occ circles:memberships --all solved this issue for me.

Yes, the Nextcloud instance exists since Nextcloud 12.

However, running occ circles:memberships --all did not change anything. The output ends with:

0 memberships updated

And the issue remains: adding a user group in the collective circle does not give any of the users access to the collective. I have to add the users manually.


Ok, issue solved :slight_smile:. It seems, the database was damaged. After restoring an older version everything works fine now.

I am also having this issue. Running occ circles:memberships --all did not solve the problem, and I don’t have the option to restore a previous database. Any other suggestions?

EDIT: I finally got this to work by running the following:

occ circles:sync


1 Like

Had the same here for a specific user. occ circles:sync by pjrobertson was the solution. Is it possible to shift the solution-marker there?

Yes, no problem. I moved the solution marker to your post.