How to setup Nextcloud Talk Recording Backend?

I have apache as well, probably thats the reason

Hi, I just wanted to mention that Nextcloud AIO bundles the recording server since v6.1.0 and there it works without any problem. It also uses Apache as web server so that should not be the reason.

thank you! i didn’t notice the extra check box in the options after the update but it’s all installed and working now!

1 Like

Like @kaisa-pg I too use the standalone signaling server from strukturag and nginx. I use docker but only at a basic level, so I like I think many others would love some basic documentation please.

I could switch to using the Nextcloud spreed but I assume that is not going to help without documentation even after the #9177 merge.

I don’t use the AIO bundle, I have a setup which exists since nextcloud was still owncloud, so its all stand alone and partially with docker.

Could someone post a guide/link or something similar how to install and configure the recording backend to enable call record in Nextcloud please?

Thanks a lot

2 Likes

After sometimes, finally my ‘high performance backend’ is up and running.

I try to figure out how to add the recording feature. Currently when I click on “start recording” option into the conversation, it hang in “starting to recording” state, without start or record anything. What I miss? I have to install something on the backend?
It is not included in the last nextcloud 27 with last version of talk app installed on it?

I added exactly the same url of signaling server into the nextcloud talk backend setting.

COuld you give me some advice on this please?

this is the error:

[no app in context] Error: GuzzleHttp\Exception\ClientException: Client error: POST https://hpb.nextcloud.domain/standalone-signaling/api/v1/room/xi78kthr resulted in a 403 Forbidden response:
Authentication check failed

Thanks

I think to understand that I have to install a docker container to put in place a separate talk recording server.
Could you provide the right command to deploy the container? I don’t understand how to setup it, and I don’t find any documentation about it on the links provided until now.
Someone could help about it?

@Chartman123 seems that you are able to deploy it, could you help the community to understand how to put in place this backend?

Thank you in advance.

1 Like

@Marco1 no, I don’t run a recording backend. I just added the links with more information to this thread :slight_smile:

1 Like

Who can help on this subject?

Anyone who has it running, and is willing to write a tutorial… :wink:

1 Like

Come on guys! Do a good deed :slight_smile: for the community!

Maybe there is a method to adapt AIO nextcloud recording container

docker pull nextcloud/aio-talk-recording

I installed it and I try to change the start.sh (read only) file inside the container and the conf file (regenerated everytime the container restart) but without success

Success! It’s working! :star_struck: :partying_face:

I made as well a docker image from AIO github for talk recording server.
Hope you will find it helpfull. :slight_smile:

https://hub.docker.com/r/surfparadise/talk-recording-standalone

1 Like

It works. Thank you for your great work. :partying_face: :dancing_women:

1 Like

Have you finished creating the document to set up talk recording? I need it rn :sweat_smile:

1 Like

I managed to get it to work with the docker container from the AIO project following the success from surfparadise.

I’m not sure why the need for a separate docker container. Granted it’s a quick and dirty to get up and running. There are probably things one should to to improve security (like find a way to make it without ALLOW_ALL=true)

Prerequisite would be to make sure you have the talk High Performance signaling setup correctly as well as setup docker correctly

  1. run “docker pull nextcloud/aio-talk-recording”
  2. run the container with the following command
    “sudo docker run -d --name talk-recording -e ALLOW_ALL=true -e HPB_DOMAIN={my_hpb.domain} -e NC_DOMAIN={my_nextcloud_domain} -e TZ={Country/City} -e RECORDING_SECRET={secret} -e INTERNAL_SECRET={secret} -p 1234:1234 nextcloud/aio-talk-recording:latest”
  3. edit /etc/signaling/server.conf and add
    [clients]
    internalsecret = {secret}
  4. on the Nextcloud Talk Admin settings for Recording backend use (assuming same machine)
    http://127.0.0.1:1234 (leave ssl unchecked)
    and enter the {secret} below

Hope that helps.

I have installed Nextcloud AIO with recording server. Container is running and on the admin panel backend is registered. But: If I start a talk call there is no possiblity to record the session. Am I missing an App?

Recording might only be possible in group conversations… Or it is hidden in the dropdown menu…

It is hidden in the dropdown menu