How to setup Nextcloud Talk Recording Backend?

I have nextcloud 26 and talk 16.0.2.
I run already the nextcloud signaling server from GitHub - strukturag/nextcloud-spreed-signaling: Standalone signaling server for Nextcloud Talk. with apache reverse proxy.
How can i install the record backend of talk on my server?

best regards


hi @kaisa-pg welcome back to the forum :handshake:

Please use the search - lot of issues have been discussed already.

Please show what you tried and which problems you hit so far!

I am also looking for the instructions on how to setup the “Recording backend” on Nextcloud 26. From my understanding the Talked app is no longer needed and recording capabilities are now built in. Just looking to set this up.

1 Like

Theoretically, I simply updated. Signaling to the last status and Talk as well as Nextcloud. However, I did not find the Record function in Talk settings, App settings or Signaling Conf.

There’s a Pull Request on Github that will add a dockerized solution. You could have a look at the proposed changes and see how to use the recording backend. To put in a nutshell, it’s a Python based part of the Talk server app.

could you share the github link?
I currently use GitHub - strukturag/nextcloud-spreed-signaling: Standalone signaling server for Nextcloud Talk. with docker-compose.

So that will be merged into the talk server app- By that means with an app update some day it will work ?

No, it’s a separate part of the app that has to be installed somewhere. If you want to know more about it, you must have a look at the files inside that PR. :slight_smile: Unfortunately there’s currently no other documentation available on how to install and run it.

OK, thank you very much.
It would be still very cool if there would be a documentation therefore, especially as it was presented as one of the next big things with NC 26 :wink:


The new feature will be primarily used by larger (enterprise) installations with support contracts. But yes, more documentation wouldn’t be a bad thing here.

I was setting it up and it seems to be correct, but I cannot see the record button in my talk session, why??

I am going to tackle this over the coming weekend. I will document everything I do. Once it is working I will revert back here and post a link to a walkthrough.


Perfect :slight_smile:
I was using the recording folder from the git-repo.

Are there already news about the recording setup?

I have still never been able to get the recording server to work. I have the secret in, but maybe the config file the docker is not correct. I edit the config file (/etc/nextcloud-talk-recording/server.conf) and added the secret, but it doesn’t seem to make a difference.

When I start recording I get this error from the recording server:

INFO:werkzeug:Press CTRL+C to quit recording: https://domain/ jyooxp6n
INFO:werkzeug: - - [13/Apr/2023 21:13:01] “POST /api/v1/room/jyooxp6n HTTP/1.1” 200 - to start recording: https://domain/ jyooxp6n
Traceback (most recent call last):
File “/usr/local/lib/python3.8/dist-packages/nextcloud/talk/recording/”, line 170, in _startRecordingService
service.start(actorType, actorId)
File “/usr/local/lib/python3.8/dist-packages/nextcloud/talk/recording/”, line 195, in start
File “/usr/local/lib/python3.8/dist-packages/nextcloud/talk/recording/”, line 458, in joinCall
raise Exception(f"No configured signaling secret for {settings[‘server’]}")
Exception: No configured signaling secret for https://signaling.domain/standalone-signaling/

@SECA do you have a running HPB (signalling server)?

I have the signaling server on a separate machine. I put the recording docker on the same server as nextcloud. I thought recording was a separate server. Also, I was not sure if it needed to be on the same box so it can save the recording to the shares. My HPB is on the same network. I plan to expand to have a second HPB after I get recording working. My HPB works just fine. No issues with normal talk use.

Check the URL of the backend. Something is probably missing in the recording server config.

I wonder if it is not really using the /etc/nextcloud-talk-recording/server.conf.

When I do: ./
Starting recording backend
No configured backends
No configured signalings

But they are configured.