How to set default language for all Collabora/Nextcloud Office files?

We are using Australian English on our Nextcloud instance. We’ve got the following in our config.php:

        "default_phone_region": "AU",
        "default_locale": "en_AU",
        "force_locale": "en_AU",
        "default_language": "en",
        "force_language": "en",

It works great. However, Collabora doesn’t seem to follow this, nor is the AU language even available. It always defaults to American English:

\

But we could use UK English in the interim.

So, how do I tell Collabora to always use UK English by default though, for everything? (i.e. all newly created files, whether templates or not)?

And as an aside, is there a possibility Australian English will be available in Collabora in future?

Thanks,
E

I think your question is better placed in https://forum.collaboraonline.com/

Shortly the was similar question:

you can control available dictionaries within Collabora config > Allowed dictionary languages

But most likely the language come from the template file you use to create your documents. So adopting Office template files should do the trick - for existing documents you will need to change the language manually…

Hi there, thanks for the answer and for that link. Unfortunately it’s not quite an answer I think. It mentions setting an environment variable with Docker that didn’t work for the OP, and we’re not using Docker anyway. We’re using the Collabora Online - Built-in CODE Server and Nextcloud Office apps bundled with Nextcloud.

Apologies, I should’ve been more clear.

Anyway, one option then. Where are the files that Collabora/Nextcloud Office apps uses as blanks? For example, with OnlyOffice and Nextcloud we could hack the core files in /var/www/nextcloud/apps/onlyoffice/assets/en-US/ (such as new.docx for example) to save over a version of that blank file with the dictionary already set to Australian English, which would be used as a new file for all users by default. Nextcloud would complain about file integrity check failing, and it wasn’t a good solution since the files always got wiped out after every update, but it was something to get the behaviour we want.

I understand users can have individual templates (but only if they set them up in their user account), so I’m wanting a solution where we can force the language globally, like we have with Nextcloud settings for everything else as posted above (and also so it’s not dependent on the user having to set their own templates—i.e. we want all new docs to be created in Australian or UK English regardless of whether a user has templates set or not). Does that make sense?

Hacking core files isn’t the best, but if there’s no config setting, a similar solution for Collabora/Nextcloud Office would work in the meantime while the software matures?

But I hope there’s a config setting or something else I can do, if someone knows how!

Thanks,
E

Oh, I should also provide more detail about versions:

Collabora Online - Built-in CODE Server
22.5.401

Nextcloud Office
6.1.1

and we’re using Nextcloud 24.0.3.

Thanks!

I know this is not the exact answer. The idea was to point you into right direction. This forum is run by unpaid enthusiasts - don’t expect somebody else will solve your really specific issue… folks here are happy to help, but you have to go the last mile to solve the problem (and hopefully report the solution)…

visiting Settings > Office as admin user you will find this setting - is likely what you are looking for

Oh please don’t get me wrong, I’m here for the same reasons and I appreciate your answer. :smiley:

I tried adding a in Settings > Office called “New.docx” that contained all the default settings we’d like, but we got this error message:

“… Only template files can be uploaded.”

Any ideas on how I make a template file inside Nextcloud with the Collabora settings we want?

Thanks!
E

I’m sorry I have the feeling you are kidding…
.docx is not a template and definitely not a Collabora format…

Create a template file with LibreOffice Writer and upload it:

image

then you can choose this template when creating new text document (and follows the language you defined there):

image

Aha, thank you for that. :slight_smile: We are getting close to solution. I didn’t realise external tools (LibreOffice) were needed and that only OTT files could be used, even though we are using the OOXML option turned on:

The problem now is that I created Blank.ott to overwrite the default “Blank” template (with our desired always-default language settings, etc), but it didn’t take. Instead we have option for “Blank” and the “Blank” template. Is this a bug now I wonder?

Screenshot from 2022-07-30 05-57-29

The same problem also occurs if I try creating a Blank.dotx using LibreOffice also.

Thanks,
E

I’ve also found this post and also tried doing what they did (which is what this documentation says) and replacing document.ott with our desired template in appdata_[instanceid]/richdocuments/empty_templates/ but that didn’t work either unfortunately…