How to restore a borg created image from cli

Looking for cli alternative to built in borg restore

Before restores started being an issue, whenever the containers wouldn’t start I would just restore from the most recent backup and be back online. But now that this error is a bug:

The borg restore failed with this error:
Restoring ‘20240125_030148-nextcloud-aio’…
fuse: mount failed: Permission denied
Could not mount the backup!

restoring from the admin interface is impossible.

Now today I started NC and the containers wouldn’t start. I did nothing special yesterday and ncdata is mounted and the logs don’t indicate anything of significance that I can see.

Instead of spending days trying to troubleshoot, is it still possible to restore the last backup but through the command line? If so, then what commands do I use for this? Keep in mind that whenever I try an occ or php command I’m told that both commands aren’t found even if I run them from the NC installation folder.

Basically a continuation of this post:
Go there if you want specs of my system

Nextcloud version 7.11.0
Operating system and version Ubuntu 22.04
Apache or nginx version unknown. OS says apachectl and http command not found
PHP version (eg, 7.4) : unknown. OS says php command not found

My installation folder (I believe):

Hi, this should be fixed wirh AIO v7.11.2

I stopped the conainers with
sudo su

docker exec -it nextcloud-aio-mastercontainer sudo -u www-data php /var/www/docker-aio/php/src/Cron/StopContainers.php

Update the containers and started a restore. It failed with this log:

Restoring ‘’…
usage: borg mount [-h] [–critical] [–error] [–warning] [–info] [–debug]
[–debug-topic TOPIC] [-p] [–iec] [–log-json]
[–lock-wait SECONDS] [–bypass-lock] [–show-version]
[–show-rc] [–umask M] [–remote-path PATH]
[–remote-ratelimit RATE] [–upload-ratelimit RATE]
[–remote-buffer UPLOAD_BUFFER]
[–upload-buffer UPLOAD_BUFFER] [–consider-part-files]
[–debug-profile FILE] [–rsh RSH] [–consider-checkpoints]
[-f] [-o OPTIONS] [–numeric-owner] [–numeric-ids]
[-P PREFIX | -a GLOB] [–sort-by KEYS]
[–first N | --last N] [-e PATTERN]
[–exclude-from EXCLUDEFILE] [–pattern PATTERN]
[–patterns-from PATTERNFILE] [–strip-components NUMBER]
borg mount: error: argument REPOSITORY_OR_ARCHIVE: Invalid location format: “/mnt/borgbackup/borg::”
Could not mount the backup!

I rebooted and tried the restore again.
and it worked.

Thanks again for your help,

much appreciated

This topic was automatically closed 8 days after the last reply. New replies are no longer allowed.