How to resolve server replied "423 Locked" to "PUT https://

[details=“Support intro”]

Sorry to hear you’re facing problems :slightly_frowning_face: is for home/non-enterprise users. If you’re running a business, paid support can be accessed via where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:


Or for longer, use three backticks above and below the code snippet:

Nextcloud version (eg, 18.0.2): 17.0.3
Operating system and version (eg, Ubuntu 20.04): Raspbian GNU/Linux 10 (buster)

Apache or nginx version (eg, Apache 2.4.25): Apache/2.4.38 (Raspbian)
PHP version (eg, 7.1): 7.3.19-1~deb10u1

The issue you are facing: My sync client gives me an error that reads "how to resolve server replied “423 Locked” to “PUT https://URL /to/path” and at that destination I have three files (on my localsystem, on the nextclaud server it is two only). The files on my local disk have extensions like .uvmpw, .uvoptx & .uvprojx and they are all different sizes but only the largest file seems to have the complete contents. To resolve the issue, do I just delete the “invalid” files and change the extension of the correct file? How else should I resolve this?

Is this the first time you’ve seen this error? (Y/N): Y

Steps to replicate it:

  1. I’m not actually sure how this situation appeared to begin with, my assumption is, that two clients at the same time wanted to sync the same file…?

The output of your Nextcloud log in Admin > Logging:

Can't see related logs on the server side

The output of your config.php file in /path/to/nextcloud (make sure you remove any identifiable information!):

$CONFIG = array (
  'instanceid' => 'ID',
  'passwordsalt' => 'salt',
  'secret' => 'secret',
  'trusted_domains' => 
  array (
    0 => 'raspi',
    1 => 'IP',
    2 => 'URL',
  'datadirectory' => '/var/nextcloud/data',
  'dbtype' => 'sqlite3',
  'version' => '',
  'overwrite.cli.url' => 'http://raspi/nextcloud',
  'installed' => true,
  'maintenance' => false,
  'theme' => '',
  'loglevel' => 0,
  'mail_from_address' => 'name',
  'mail_smtpmode' => 'smtp',
  'mail_sendmailmode' => 'smtp',
  'mail_domain' => '',
  'mail_smtpauthtype' => 'LOGIN',
  'mail_smtpauth' => 1,
  'mail_smtphost' => '',
  'mail_smtpport' => '465',
  'mail_smtpsecure' => 'ssl',
  'mail_smtpname' => '',
  'mail_smtppassword' => 'pass',
  'blacklisted_files' => array('.htaccess'),
  'onlyoffice' => 
  array (
    'verify_peer_off' => true,
  'app_install_overwrite' => 
  array (
    0 => 'twofactor_rcdevsopenotp',

The output of your Apache/nginx/system log in /var/log/____:


Make sure that you’ve configured a ile locking mechanism:

Thanks for your reply, he link you posted reads:

File locking is enabled by default, using the database locking backend.

Do you think I should memcache locking with redis, instead? And still, how will this resolve the problem?

It might be important to configure at least one locking mechanism in Nextcloud. I cannot find any related configuration line in the provided configuration (or have I overlooked it?!). BTW, I’m personally really satisfied with Redis.

It says it’s enabled by default so I don’t think any further configuration should be required, right?

As far as I know the database locking mechanism is usually slow and generates massive IO traffic on the database. I would recommend not to use the database but Redis etc. as described in the administrator guide.

Have a look over here. Old and present problem once in a while.