How to move exisiting Nextcloud instance to new server


#1

Dear all.

I do have working nextcloud instance. But I would like to move it to new server.
I’m using currently database hosted on NAS (QNAP), and data directory on the same NAS using iscsi.
Now I think, I want to migrate Database from Nas to local mariadb, which I think should be faster (correct me please, if I’m wrong).
So far I have no idea if I can simply export, import database ?
Or how to make this migration painless.


#2

and don’t forget to turn on maintenance mode before and off after. and modify the config.php to point to the new database.


#3

Thanks, really stupid question – if I am able to retrieve the hard disk and use it to boot with new hardware, what do I need to look out for ?

I would hope that just booting from new motherboard/cpu/etc with the same boot drive would work but it just did not – I am little unsure why, any pointers were to look


#4

first of all look at “the error message”.
where does the boot fail with what kind of error?


#5

Hi Reiner, danke für die Antwort!

(back to English to make it more useful for all)

that was really imprecise, my apologies :slight_smile:

here a better description of what is happening.

we have moved and I am considering retiring the separate server and just running keep the HTPC I have running and port my nextcloud to that

when I plug the 18.04 SSD that holds the nextcloud system into the HTPC it all boots fine, I should have said that, apolgies.

so I can get the computer up to where i expect it with command prompt live on an ubuntu 18.04 instance and an installed Nextcloud 15.05

When I tried to acces the NC15 I ended up with permission denied apache error 403 whenever I tried accessing the nextcloud instance – I found this quite confusing and I am not sure which logs I should check as I could not see anything immediately


#6

ok. there should be an entry in the apache log. i guess in /var/log/apache2/


#7

thanks @Reiner_Nippes

Just for reference the thing I had not thought about was my router, despite ensuring forwarding etc all was right I actually needed to turn DHCP on / off and force the right IP going to new motherboard…