How to hide "discuss this file"-sidebar when sharing a file externally

Support intro

Sorry to hear you’re facing problems :slightly_frowning_face:

help.nextcloud.com is for home/non-enterprise users. If you’re running a business, paid support can be accessed via portal.nextcloud.com where we can ensure your business keeps running smoothly.

In order to help you as quickly as possible, before clicking Create Topic please provide as much of the below as you can. Feel free to use a pastebin service for logs, otherwise either indent short log examples with four spaces:

example

Or for longer, use three backticks above and below the code snippet:

longer
example
here

Some or all of the below information will be requested if it isn’t supplied; for fastest response please provide as much as you can :heart:

Nextcloud version (eg, 20.0.5): 20.0.14
Operating system and version (eg, Ubuntu 20.04): ?
Apache or nginx version (eg, Apache 2.4.25): ?
PHP version (eg, 7.4): ?

The issue you are facing: How to hide “discuss this file”-sidebar when sharing a file externally

Is this the first time you’ve seen this error? (Y/N): N

Steps to replicate it:

  1. (have talk app activated)
  2. share a file via public link
  3. open the link
  4. see a sidebar on right: “discuss this file - join conversation” (German “Diese Datei besprechen - Unterhaltung beitreten”)
  5. There is no way to deactivate this sidebar in the sharing settings? I don’t want people to see it because it confuses them more than it helps them.

Thank you for your thoughts!

You can disable it in the Talk settings:

English:
https://i.imgur.com/8PvbSDh.jpg
German:
https://i.imgur.com/v2DJtnc.jpg

Thank you!!