How to get Collabora (Nextcloud Office) working on nextcloud 23?!

Really needing some help here, I’ve followed all of those instructions including the one where you install the old version of richdocuments to no avail. I seem to be getting a different error.

I am running Debian 10.11 with Nextcloud 23 and Collabora 5.0.1 now. PHP 7.4.26. Single server with the Collabora Online - Built-in CODE Server installed as well (21.11.6). Old version 4.1.2 of Collabora also did not work so I just updated it. No docx or xlsx document will open, they just try and download to the desktop. The only error I see in the nextcloud log is this one:

GuzzleHttp\Exception\ConnectException: cURL error 28: Operation timed out after 10001 milliseconds with 0 bytes received (see https://curl.haxx.se/libcurl/c/libcurl-errors.html) for https://nextcloud.domain.ca/apps/richdocumentscode/proxy.php?req=/lool/convert-to/png

Help!

I eventually got it to work after trying a few things, could have been this line in config.php: ‘allow_local_remote_servers’ => true,

Glitchy POS.

Hi,
For me this “workaround” worked: Go to “office” in the settings, activate “Use own server”. This does not work or brings an error message. Then select again “Use the built in code server”.After that it worked for me. Don’t ask why.
schnick

That doesn’t work for me.
I have 8 GB RAM and only 5,5 GB are used. There should be enough space for the CODE server. CPU works with 30 - 50 %. The connection to the CODE is green. I have no more ideas.
Perhaps I have to wait for an update.