How do I point Nextcloud Office app at a differnte URL?

Server Type Thinkcentre TIny i3
Environment Yunohost (Stable)
Nextcloud Version 28.0.3~ynh2
Collabora Version

I first installed Collabora on my top level domain, which was stupid. I am trying to remedy this. I have reinstalled Collabora and specified the correct subdomain in the install process, but Nextcloud is still looking for the TLD as in this image:

The box that displays the Collabora URL is not editable.
I have tried uninstalling and reinstalling Nextcloud Office but that hasn’t changed the setting.
I would be grateful for any advice.

I have ssh access and am reasonably comfortable in the command line, if I know what I’m looking for. :crazy_face:

I’ve seen some reports that the settings web UI may be flakey for some people at the moment. There’s an open bug report. There was a PR merged for some of it recently (the WOPI parameters), but I haven’t had the opportunity to see whether it was for the rest of the UI too.

Fortunately all of the parameters are adjustable at the command line.

occ config:list richdocuments should show your current Office configuration. All of those shown parameters can be modified/set via occ config:app* commands:

Don’t forget to activate when parameters are set:

1 Like

Thank you very much for this.
An added complication is that I am on a Yunohost server so can’t directly access occ commands. However, I have found the way round that here. This is just to explain my weird looking code.

I got occ access with:

sudo -u nextcloud php8.2 --define apc.enable_cli=1 occ

then tried the command you gave me, added to the funny occ exception:

sudo -u nextcloud php8.2 config:app:set --value ${} richdocuments wopi_url

(with my actual domain in the place of the word domain)
which gave me

Could not open input file: config:app:set

I’m a bit spent from staring at the shell now, so I’m going to come back to it fresh tomorrow night. Thanks for your help. I’ve got the git page you linked to saved and will see whether I’ve missed anything from that.

In the meantime, thanks again.

Change to the /var/www/nextcloud/ folder…

cd /var/www/nextcloud

…and the run the command as follows:

sudo -u nextcloud php8.2 occ config:app:set --value="" richdocuments wopi_url

Alternatively, you could add the path to the command:

sudo -u nextcloud php8.2 /var/www/nextcloud/occ config:app:set --value="" richdocuments wopi_url
1 Like

Thanks bb77.

That gave me this:

An unhandled exception has been thrown:
OCP\HintException: [0]: Memcache OC\Memcache\APCu not available for local cache (Is the matching PHP module installed and enabled?)

which I guess is a quirk of my setup.

I’m posting the solution that worked below. Thanks again.

Sorted with generous help from several people here and on the Yunohost forum.

Full solution:

sudo yunohost app shell nextcloud

This produces a readout of all the nextcloud settings as they stand.


php8.2 --define apc.enable_cli=1 occ config:app:set --value="" richdocuments wopi_url

Output from that:

Config value wopi_url for app richdocuments set to

When I looked at the Office page in the administration settings of Nextcloud UI, the correct domain was displayed and a green tick showed that the Collabora server was reachable. My documents opened. Joy was unconfined.

Many thanks to @jtr and @bb77


Ah yes, I missed that one. Anyways, glad it worked out, and thanks for posting the solution. :slight_smile:

1 Like