How do i implement a change / pullrequest available on github?

Nextcloud version 11.0.2
Operating system and version: techandme nc-vm image
Apache or nginx version (eg, Apache 2.4.25): 2.4.18

Hi! I want to get the change that @schiessle made recently running on our nextcloud (

i’m not very familiar with linux and the usage of github, so can anyone help me to get these changes from this pullrequest into our nc?

any help appreciated :slight_smile: thanks!

hi tflidd!
thanks for your input

i tried to follow jos’s instructions, but ran into a problem:

changed path to /var/www/nextcloud
grabbed the patch there
tried the dry-run in this folder brought:

root@nc:/var/www/nextcloud# sudo patch -p1 --dry-run < 4136.patch
can't find file to patch at input line 16
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|From b50f9b9aef4c358eeb389c6e5d3b856783622e65 Mon Sep 17 00:00:00 2001
|From: Bjoern Schiessle <>
|Date: Mon, 27 Mar 2017 22:03:10 +0200
|Subject: [PATCH 1/8] allow the user to set a expire date for all shares
|Signed-off-by: Bjoern Schiessle <>
| core/css/share.scss                  |  4 ++++
| core/js/sharedialogshareelistview.js | 34 ++++++++++++++++++++++++++++++++++
| 2 files changed, 38 insertions(+)
|diff --git a/core/css/share.scss b/core/css/share.scss
|index 0e6eb3c..3ca2e4e 100644
|--- a/core/css/share.scss
|+++ b/core/css/share.scss
File to patch:

to me it looks like i’m in the correct folder, since the files here are starting with core/…
i even tried it with the p0 option, same issue

what am i doing wrong here?

thanks again!

ok, another day another try…

if i get it right, the -p1 option would remove the first part of core/css/share.scss and core/js/sharedialogshareelistview.js respectively, making

css/share.scss and

from it. so obviously that would be a problem if i am calling this from /var/www/nextcloud - i should move into the /core directory
but i also have the same issue with the p0 option, which should give the right path from where i’m calling patch

please assist me with this - thanks

if i try to give the path at the File to patch: prompt it’s no good either

no luck